Search found 1 match

by fkosmalla
Mon Mar 27, 2017 7:07 am
Forum: ARENA & Expression
Topic: Arena 1.7 or earlier?
Replies: 4
Views: 1213

Re: Arena 1.7 or earlier?

Hello, I ran into a problem, I wanted to try out mocap at my university, but it appears that the license of Arena expired on 2012, January. As I understand it will still run with older versions of Arena, but I can't find downloads anywhere... Maybe someone here has an old installer or knows where I...