Search found 513 matches

by beckdo
Mon Nov 17, 2014 4:29 pm
Forum: Motive
Topic: (1.7 Beta 2) AddTrackables does not seem to be working
Replies: 5
Views: 1114

Re: (1.7 Beta 2) AddTrackables does not seem to be working

I've reviewed the implementation as well tested this functionality today via a modified Motive 1.7B2 sample application and it appears to work correctly in Motive 1.7B2.
by beckdo
Thu Nov 13, 2014 1:49 pm
Forum: Motive
Topic: Motive 1.7 Beta 2. NPTrackingTools API Issue
Replies: 1
Views: 612

Re: Motive 1.7 Beta 2. NPTrackingTools API Issue

Thanks for reporting this Jeff. We will get this addressed for Motive 1.7 Final.
by beckdo
Mon Oct 27, 2014 2:26 pm
Forum: Camera SDK
Topic: Avoiding ethernet cameras initialization
Replies: 2
Views: 997

Re: Avoiding ethernet cameras initialization

Before making any calls into the Camera SDK, ideally near your process' entry point do this: cCameraLibraryStartupSettings::X().EnableEthernetDevices(false); This will disable all Ethernet devices, communication over sockets, and any packet communication. Basically this prevents the entire Ethernet ...
by beckdo
Wed Aug 06, 2014 2:13 pm
Forum: Camera SDK
Topic: Weird SDK behaviour
Replies: 5
Views: 1681

Re: Weird SDK behaviour

Ok, great MSVC is the way to go of course. We don't support MingW. We use QT here internally for many internal tools. I have not experienced any of the things you're describing. I'm not sure why you're seeing this but depending how you've coded against the Camera SDK, there's certainly the possibili...
by beckdo
Wed Aug 06, 2014 2:08 pm
Forum: Camera SDK
Topic: VS2013 build
Replies: 6
Views: 2072

Re: VS2013 build

Hey Nicholas,

Are you just getting corruption on object that you are instantiating from your code or other objects?

I'd really like to get more specific details.

We don't currently offer a VS2013 binary, but it'll be coming before too long.

Thx,
Doug
by beckdo
Tue Jul 22, 2014 11:32 am
Forum: Camera SDK
Topic: Weird SDK behaviour
Replies: 5
Views: 1681

Re: Weird SDK behaviour

Are you using mingw or MSVC as your compiler?
by beckdo
Thu Jul 17, 2014 11:11 am
Forum: Camera SDK
Topic: GetCamera() not working in secondary threads
Replies: 3
Views: 1225

Re: GetCamera() not working in secondary threads

Hey Francis, The Camera SDK is multi-thread safe. Users are encouraged to implement the approach you've described if they want to fetch cameras from the Camera SDK from any thread. There are a couple of important things to note with your approach. Calling he GetCamera() method without any parameters...
by beckdo
Tue Jul 08, 2014 12:37 pm
Forum: Camera SDK
Topic: Camera SDK + Qt = runtime error
Replies: 13
Views: 7210

Re: Camera SDK + Qt = runtime error

It's important to note on this thread that we've been shipping both the /MT and /MD versions of the Camera SDK for a few years now. If anyone else has issues or more information regarding using QT and the Camera SDK together in their applications please feel free to add that information here. We hav...
by beckdo
Thu Jun 12, 2014 11:52 am
Forum: Motive
Topic: How is "Reset to current orientation" computed?
Replies: 1
Views: 677

Re: How is "Reset to current orientation" computed?

When Reset to current orientation is computed, it reorients the rigid body markers, so that the rigid body, based on it's current pivot point and orientation so that the rigid body reports 0,0,0,1 for quaternion orientation, and 0 for yaw, pitch, and roll. Position results remain unchanged. It's cal...
by beckdo
Thu Jun 12, 2014 11:48 am
Forum: Camera SDK
Topic: GetFrameGroup return null
Replies: 3
Views: 1364

Re: GetFrameGroup return null

Hey guys, Let me give you some more information regarding synchronization. I would suggest reviewing the FrameSynchronization sample. The basic approach you should implement is to observe connected cameras in the CameraList. Once you have cameras in the CameraList, you should fetch pointers to those...