GPLshift v0.710 Out

JSJ
Posts: 76
Joined: Fri Oct 18, 2002 5:00 am
Location: Copenhagen, Denmark

GPLshift v0.710 Out

Post by JSJ » Wed Jun 15, 2005 4:56 am

oops, It seems I have forgotten to annonce that I have released 0.710 with add of TIR DOF Y support. (May 28) for GPL

JSJ
http://www.gplshift.dk/

Rushman
Posts: 26
Joined: Fri Feb 06, 2004 5:00 am

Re: GPLshift v0.710 Out

Post by Rushman » Fri Jun 17, 2005 5:19 pm

Thanks JSJ ! Yes, there are people here looking for your improvements/additions.

I know I speak for many.

Thank you.
Rushman

Bran
Posts: 104
Joined: Tue Oct 04, 2005 5:00 am
Location: Germany

Re: GPLshift v0.710 Out

Post by Bran » Tue Oct 18, 2005 11:45 pm

Hi JSJ,

I appreciate your work on GPL since your beginning.
I just installed GPL (inluding that GPLEA '67 high poly cars mod) and GPLshift 0.710 again and wanted to see how the TiR vector enhancement works.
In short words: EXCELLENT!!!

When taking your time to edit the .ini-file, one really gets a good result. I would like to say, that, if I move the view on the x-axis, I cannot turn the head to look left/right. Wich means either move your head "like an agyptian " on the x-axis or look left/right, you cannot do both. Or am I doing something wrong?
Furthermore: I you possibly could implement a "roll"-view; I guess everybody would give you 11 out of 10 points

lou_magyar
Posts: 4
Joined: Wed Nov 30, 2005 5:00 am
Location: Bloomington, Indiana, USA

Re: GPLshift v0.710 Out

Post by lou_magyar » Tue Nov 29, 2005 10:30 pm

Hi JSJ,

I am trying to get GPLShift to work with my new TrackIR4 and keep getting a CTD from GPL when i try to run it after i patch it.

I changed the settings in the 'ini' file. any suggestions?

mmed
Posts: 83
Joined: Sat Nov 27, 2004 5:00 am
Location: Sweden

Re: GPLshift v0.710 Out

Post by mmed » Wed Nov 30, 2005 1:20 am

Thanks JSJ, much appreciated.

lou_magyar
Posts: 4
Joined: Wed Nov 30, 2005 5:00 am
Location: Bloomington, Indiana, USA

Re: GPLshift v0.710 Out

Post by lou_magyar » Wed Nov 30, 2005 12:39 pm

mine is already set to '0'.

JSJ
Posts: 76
Joined: Fri Oct 18, 2002 5:00 am
Location: Copenhagen, Denmark

Re: GPLshift v0.710 Out

Post by JSJ » Wed Nov 30, 2005 5:36 pm

Thanks guys

I am working with update of v0.710 and have discoved a error in the "ViewCarEngine&RearWheel = 1" support (CTD)
so change it to "= 0"

Any luck? lou_magyar

BTW v0.720:
Will have a automatic detecting & support of TrackIR
(no need for "LookAroundMode = 1.TIR" anymore)
You can use both the TIR & Buttons in same time
e.g. user TIR in Look L/R 0-45 degress and button(s) in quick 75/122deg. view

JSJ

[ November 30, 2005, 01:49 PM: Message edited by: JSJ ]

JSJ
Posts: 76
Joined: Fri Oct 18, 2002 5:00 am
Location: Copenhagen, Denmark

Re: GPLshift v0.710 Out

Post by JSJ » Wed Nov 30, 2005 7:33 pm

quote:Originally posted by lou_magyar:
mine is already set to '0'. Strange
Can you send me your gplshift.ini, or show it here

What GPL version do you have (v1.2.0.1/1.2.0.2/Demo2004, UK/US/SP/ etc)

Little Test:
Move gplshift.dll to another dir. still CTD?

JSJ
jsj@gplshift.dk

[ December 01, 2005, 03:12 AM: Message edited by: JSJ ]

lou_magyar
Posts: 4
Joined: Wed Nov 30, 2005 5:00 am
Location: Bloomington, Indiana, USA

Re: GPLshift v0.710 Out

Post by lou_magyar » Thu Dec 01, 2005 7:35 am

moving the gplshift.dll indeed prevents the CTD - but trackIR does not work.

There is something going on when i get into the car. up until that point, it behaves normally. as soon as i try to get into the car, the monitor resolution changes <click> and i get a CTD. without the DLL, there is no resolution change and no CTD.

is there an undocumented requirement that GPL be run in a window? or that the GPL resolution be the same as the monitors?

I am running the full USA version, from CD (yeah, i've had it since 1998) with 1.2.0.2 patch, and using the Bandwidth patch, option 3, and TrackIR4.

here is my gplshift.ini file. i removed all the comments (those are great BTW) to make it smaller.
===============

INI v0.710 - DO NOT chance anything on this line!

[ Shifter Unit ]
Shifter_Model = NONE
Shifting_Behaviour = 1
Switch_Between_Modes = OFF

[ Clutch Device ]
Clutch_Threshold = 0
Clutch_Shift_Sound = OFF

[ CAR RESET ]
Button_Number = OFF

[ REPLAY START/STOP ]
Button_Number = OFF

[ LOOK AROUND ]
LookAroundMode = 1.TIR
Look_Left45d_Button =
Look_Left73d_Button =
Look_Left122d_Button =
Look_Right45d_Button =
Look_Right73d_Button =
Look_Right122d_Button =
LookLeftRightDeadZone = 0
LookLRStartAngle = 0
LookLRMaxAngle = 46
Look_Up_Down = 1
ReCenter =
ViewCarEngine&RearWheel = 0

[ ZOOM ]
Zoom_In_Out_Mode = OFF
Zoom_Out_Button =
Zoom_In_Button =
Zoom_Reset_Button =
Zoom2UserDefineFOV_Butt =
UserDefineFOV = 3FAE3DA8
UserDefineSOV = 3FAE3DA8

[ DRIVER VIEW ]
Up&Down = 0
Forward&Back = 0

[ TrackIR LIFT ARM ]
LiftRightArmLevel = 0

[ SEND CHAT MESSAGE ]
Send_Message_Mode = OFF
send_"PO"_button =
send_"PI"_button =
send_"Sorry!"_button =
send"No Problem"button =

[ VOLUME CONTROL ]
Volume_Control_Mode = OFF
Volume_Up_button =
Volume_Down_button =
Volume_Mute_button =
Volume_Normal_button =

[ GPL DISPLAY ]
Set_FPS_Display_On = 0

[ GPL AXIS ]
Share_All_16_AXIS = 0
DisableUSBshifter2AXIS = 0

==============

JSJ
Posts: 76
Joined: Fri Oct 18, 2002 5:00 am
Location: Copenhagen, Denmark

Re: GPLshift v0.710 Out

Post by JSJ » Fri Dec 02, 2005 8:54 am

Hi lou_magyar

I have tested GPL 1.2.0.2 US with your gplshift.ini setup + BW v3.1 in Single/Local
Multiplay (but no other cars) and I have no problems! so I am lost here :-(

Have you installed other GPL Tool/Util/Mod patch? e.g GEM+ (v?.?) and 65Cars and
other Carset, Sound Patch? etc

Does the CTD happen only in Single/Multplay...?

Using the unpatched rast3d7.dll?

WinXP or 2K?

EDIT:
GPL can run in a window and in full size
640x480 - 1600x1200 (and higher?) if your
monitor support it
if you select in window mode

[ Rasterizer ]
fullScreen = 0

then set windows in 16bit colours

JSJ

[ December 02, 2005, 04:11 PM: Message edited by: JSJ ]

Post Reply