TIR1 and TIR2: Not USB2 compatible?

AV8R
Posts: 74
Joined: Sat May 10, 2003 5:00 am

TIR1 and TIR2: Not USB2 compatible?

Post by AV8R » Fri Dec 19, 2003 8:11 am

In trying to get more information on the TIR and why it might not be working on my newer system, USB seems to be a strong suspect in this investigation.

Simply put, were the TIR and TIR2 tested and qualified to be USB 2.0 compliant?

Referring back to the TIR2 posted technical specs, this is what is stated:
Interface: USB 1.1
Power: 5V @ 240ma from USB

The transaction translator is a function within a USB hub that automatically recognizes which USB category is connected on a particular port and translates any USB 1.1 signals to USB 2.0.
So, is a valid assumption to assume USB1.1 devices (such as the TIR1&2) are fully compatible with USB 2.0 ports (not hubs)?

Could this be the source of the problem many of us are having with the TIR (and TIR2) not being recognized by our newer PC systems with USB2.0?

technical resources referenced:
http://www.intel.com/technology/usb/
http://www.usb.org/developers/usbfaq/
http://www.tomshardware.com/consumer/20 ... ub-02.html

How about from the TIR owners, what are you seeing with USB 2.0?

AV8R

Charlie251
Posts: 955
Joined: Fri Jan 03, 2003 5:00 am
Location: Melbourne, Florida

Re: TIR1 and TIR2: Not USB2 compatible?

Post by Charlie251 » Sat Dec 20, 2003 9:57 am

TrackIR2 does not work in my USB2.0 port. Only in my 1.1 ports.

Jim
NaturalPoint Employee
NaturalPoint Employee
Posts: 1395
Joined: Mon Oct 14, 2002 5:00 am
Location: Corvallis, Oregon
Contact:

Re: TIR1 and TIR2: Not USB2 compatible?

Post by Jim » Sun Dec 21, 2003 11:50 am

Hello:

TrackIR and TrackIR2 are both USB 2.0 compatible. The 2.0 spec now incompasses that 1.0 and 1.1 spec, we are now classified as a USB 2.0 product with Full Speed operation.

We have seen a few problems on some USB hubs and some VIA chipsets, but this is usually fixed by upgrading the drivers or BIOS. In the worst case we have seen a $20 USB 2.0 card fix the problem. We have spent big bucks to make sure that we are fully USB compliant, so this is just an issue with a very small amount of users with compatiblity problems from their USB subsystem.

AV8R
Posts: 74
Joined: Sat May 10, 2003 5:00 am

Re: TIR1 and TIR2: Not USB2 compatible?

Post by AV8R » Mon Dec 22, 2003 2:07 pm

... TIR1 and TIR2 are now full speed USB2.0 and USB1.1 compliant...

USB testing compliance does not gaurantee that a device will be compatible with all or any computer systems. Thats a given.

So then, how does any customer know if they are going to be one of the "few" with this USB installation and USB device recognition problem with TIR?

It really comes down to how NP will support its product and customers, should it not work. That should guide a consumer in their decision making.

From the support statement, it appears that if it works, great. But if it doesnt, youre categorized as one of the "few". Not much practical insight is offered to solve the problem. Even a beta tester admitted to seeing this. All potential customers (first or second hand buyers) should know of this gamble apriori.

More information, like what system specs were used in the USB testing would be of interest to those that have not yet purchased their systems or TIR yet.

I welcome a more informed response. If I happen to solve this problem first, Ill be happy to post the solution.

============

Now for my case as a reference point:

In my case I have a brand new FIC Icecube with an Intel 845GE MB (similiar to the system you have pictured on NP's web page). It comes with 4 USB2.0 I/O ports:
http://www.fic.com.tw/support/motherboa ... intel.aspx

Plus I bought an Opti based USB1.1 PCI board, which didnt work either:
http://www.opti-inc.com/html/usb1394.html

TrackIR v1 is the only USB device I have that exibits an USB installation and compatibility problem. And I have had no problems with: cameras, scanners, printers, TM Cougars, MS FFB Sidewinders, wireless mice, keyboards, GPS, wireless lan adaptors, etc.

Ive tried all the reinstallation, registry cleaning, software versions, recommedations posted here. To no avail.

So why is there a problem with TIR-1 on a new system (not VIA) with latest drivers and WinXP updates?

[ December 22, 2003, 10:41 PM: Message edited by: AV8R ]

Sulky
Posts: 46
Joined: Thu Nov 06, 2003 5:00 am

Re: TIR1 and TIR2: Not USB2 compatible?

Post by Sulky » Fri Dec 26, 2003 12:47 am

Av8r,
Some have reported probs having the TIR2 and the Cougar on adjascent ports. I have no idea why this should be problematic but apparently its a reality.
Sulky

AV8R
Posts: 74
Joined: Sat May 10, 2003 5:00 am

Re: TIR1 and TIR2: Not USB2 compatible?

Post by AV8R » Fri Dec 26, 2003 6:33 pm

Hi Sulky,

In the past I had my TM Cougars and TIR1 on my 2 year old system, and it worked fine.

On my newer Intel based system, all I have is the TIR1 - which wont be recognized no matter what Ive tried. On the other hand, the TIR1 works fine a new HP TC1000. Go figure, its a crap shoot.

This is the _only_ USB device that doesnt work on this Intel (not VIA) based system. It appears the TIR is mother board / USB subsystem sensitive.

Which means the design probably requires certian IRQs or USB drive parameters that they are not aware of or are not making public.

For now, it appears we "few" are S.O.L. Im not mad, Im just very dissappointed at this lack of customer concern and support.

HarryLee
Posts: 73
Joined: Tue Nov 18, 2003 5:00 am

Re: TIR1 and TIR2: Not USB2 compatible?

Post by HarryLee » Sat Dec 27, 2003 2:56 am

Hi AV8R,

I'm also having a problem with my TIR2 not being recognized. See my posts here for details:

http://forums.naturalpoint.com/cgi-bin/ ... 2;t=000057

Is this anything like your problem as far as the driver install errors when TIR is 1st connected?

Strange thing is, it worked FINE for 2 months! Then it just quit.

I've tried installing on 3 different PC's so far - 1 with XP and USB 1.1, one with XP and USB 2.0 and finally one with ME and USB 1.1. Exact same problem on all of 'em, device is not recognized & gets installed as "Unknown Device".

I'm a little concerned that NaturalPoint is going to try to pass me off as "one of the few" like you're talking about. That would be disappointing with the LOMAC patch near release, with the TIR fix

Do you think I've got any chance of getting support? I've never dealt with their support so I don't know what to expect.

Thanks!

Lee

AV8R
Posts: 74
Joined: Sat May 10, 2003 5:00 am

Re: TIR1 and TIR2: Not USB2 compatible?

Post by AV8R » Tue Dec 30, 2003 7:59 am

Hi Harry,

Ive tried emailing NP customer support a few times and they didnt respond to simple questions w/r/t to this problem. Same thing here on this "support forum". Im not sure spending more money to call NP support will do much different, being that the posted solution is not indepth or helpful. But if you want to spend the coin on the call, go for it, and please post what happens.

Heres what the latest NP support page says, and you can judge for yourself if they really understand the problem:

================================
2. �Cannot Find the File Specified� error message.

Solution :
Ensure that your TrackIR2 unit is plugged securely into your computer�s USB port. If you are using the provided USB extension cable, ensure that all connections are tight.

You may have improperly installed your TrackIR2. If you connected the TrackIR2 unit before installing the software, do this: In Windows 98, ME, and 2000, disconnect the TrackIR2 unit. Right click on My Computer. Go to Properties. Click on Device Manager. Double click on USB devices. If you see a device listed as "unknown" or "?" remove that device and reconnect the TrackIR2 unit. If you see a device listed as "ECT tracker board" then this is not the problem. Windows XP users, please see the Windows XP installation guide in the TrackIR2 Manual.
=====================

If I had to guess, I would say there is something wierd going on with the compatibility of TIR1 and TIR2 with USB. Whether it be hardware or OS/software related is yet to be uncovered.

The best thread on this issue so far is:
http://forums.naturalpoint.com/cgi-bin/ ... 3;t=000210

But Ive seen solutions being offered from:
- buy the TIR2
- reformat the HDD
- reinstall the WinXP OS
- point to the Windows/INF folder to the USB config file.
- buy a PCI USB1.1 hub card
- disable USB2.0 on the MB
- get a different MB
- remove the USB hardware entry, and reinstall the TIR software
- admission that the USB spec was pushed to the edge by Michael York
- claims that the TIR meets all USB 1.1 and 2.0 complaince.

Like why can I grab any 5 dollar USB device and it works flawlessly on all my systems, but the $130 TIR does not? Dont insult the customer by telling them its their own system or installation as the first response. It should always be the last customer support response.

My take is that Natural Point needs to admit that they have a real compatibility problem that needs to be looked into and offer those with TIR1s an upgrade path to TIR2 or TIR3 that solves this problem effectively.

That being said, Im sure sooner or later either NP or one of our great flight simmers will come up with a viable workaround. So keep a positive attitude.

After all, its just a gaming device. Whats more important, is how we treat eachother.

AV8R
Hardware designer, applications engineer, customer support coordinator for a major Ecad vendor

[ December 30, 2003, 04:28 PM: Message edited by: AV8R ]

HarryLee
Posts: 73
Joined: Tue Nov 18, 2003 5:00 am

Re: TIR1 and TIR2: Not USB2 compatible?

Post by HarryLee » Tue Dec 30, 2003 11:03 am

Hi AV8R,

Thx for the great post I've been thru the thread you mentioned, and also NP's troubleshooting steps with no positive results. Reading that thread, I agree that there is a problem NP needs to address as far as USB compatibility.

Another strange problem I had one time when it was working was, I disconnected a couple USB devices. After restarting the computer, the NP software couldn't find TIR! After some head-scratching I hooked up the other USB stuff as before, restarted, and now the software found it... strange! (I didn't think to look in Device Manager to see if it was reported there)

Anyway, to keep you posted I received a reply from Support to an email I sent last week. He seems to agree with me that if I can't get it to install on 4 different machines, it is probably defective. He gave me a RMA to return it for testing, and promised a replacement if it turns out to be defective. Hopefully I'll be back in business in a couple weeks!

Thanks for your time, I appreciate it!

AV8R
Posts: 74
Joined: Sat May 10, 2003 5:00 am

Re: TIR1 and TIR2: Not USB2 compatible?

Post by AV8R » Mon Jan 05, 2004 9:08 pm

Harry,

Good for you. As Ive said here and in the TIR1 forum, its a crap shoot as to if its going to work on your system.

This week I built a new 3.2 Ghz Intel HT CPU powered system and TIR1 with v2.11 beta4 was recognized with a new WinXP OS install. My other gaming system that also has another TIR1 does not recognize the device. It is a 2.4 Ghz Intel CPU powered system.

Both systems use Intel CPUs and Intel MB chipsets. Both have USB2.0, but Ive disabled it for TIR1's sake. Both are running WinXP Home. Both are using the same BIOS vendor. Swapping the TIRs does not solve the problem. The TIR1s are "functional". It comes down to USB compatibility between the TIR1 and the USB devices on the MotherBoards, with the possibility of Windows USB port and hub drivers thrown into the mix.

NP pushed the edge in their design, and as a result you wont know if TIR will work until you try it. Make sure you try it with the latest MS OS updates before you are confidient of its working or not. Keep your receipt in case it doesnt work.

Good luck.

AV8R

[ January 06, 2004, 04:11 AM: Message edited by: AV8R ]

Post Reply