forums.naturalpoint.com

Discussion and Support for the OptiTrack, SmartNav and TrackIR brands by NaturalPoint

Track IR 3 does not find hardware driver

by SULLY » Wed Dec 14, 2005 12:20 pm

I also now have this problem....Was working fine ...had to move everything and had to hook everything back up to new spots....uninstalled all trackir software.....reloaded drivers 4....windows sees it but when it tries to load the drivers it gets to the this hasn't passed windows blah hit continue anyway and then system crashes to desktop....Tried uninstalling and install 3.drivers first but they crash at this point too any Ideas?

[ December 14, 2005, 07:20 PM: Message edited by: SULLY ]
SULLY
 
Posts: 33
Joined: Wed Dec 24, 2003 5:00 am

by Mace » Tue Dec 20, 2005 9:24 am

After buying this unit approx 5months ago. I have had some awesome online flight sim experiences. However, approx 1 month ago my unit was not being detected by winXP. So i disconnected and re-connected and it was fine - Until 2 days ago when it will not find the drivers.
Windows detects a "USB Device" being connected to the system but cannot find the drivers for it. I am sure it previously detected " NaturalPoint TrackIR Device" (by name).

I have tried everything known, even a clean WINXP install and i have the same problem.

Reading this thread and anticipating a problem after a clean install, i saved the registry & setupapi files before and after installation.

Pls help ....i am going cold turkey on my aerial combat !!!
Mace
 
Posts: 2
Joined: Tue Dec 20, 2005 5:00 am
Location: Australia

by andrejg » Fri Dec 23, 2005 2:48 am

I think I know what the problem is (I don't know how to solve it, though [Frown] ).

The problem is that the installer doesn't install the drivers. On "normal" systems (e.g. my sister's laptop with WinXP Home) Windows prompt for an unsigned driver install at the end of the setup and when a TIR is plugged in. On my desktop machine this doesn't happen at all.

My guess is that because the drivers are unsigned and the driver security policy is either set incorrectly (or somehow screwed - note that I have set it correctly in Local Security Settings) the driver install fails silently...

I have the same problem with Franknstik; it won't install drivers no matter what I do (and it won't even notify me that they haven't been installed).
andrejg
 
Posts: 5
Joined: Sat Oct 01, 2005 5:00 am

by Birch » Fri Dec 23, 2005 12:06 pm

Please send an email to support@naturalpoint.com with your serial number and a desription of your issue and they should be able to help you.
Birch
NaturalPoint Employee
NaturalPoint Employee
 
Posts: 1139
Joined: Thu Jan 30, 2003 5:00 am
Location: Corvallis, Oregon

by Mace » Sun Dec 25, 2005 2:07 pm

Thanks guys for yr input....

Birch,
I have been liasing with Rick from NaturalPoint re this problem and has agreed to provide a RMA for me.
I suggested that an upgrade option to Trackir Pro4 at my expense, but he would not entertain the idea.

For less than 30hrs use from this product i would have expected better !! [Frown]

[ December 25, 2005, 09:27 PM: Message edited by: Mace ]
Mace
 
Posts: 2
Joined: Tue Dec 20, 2005 5:00 am
Location: Australia

by Ajax » Wed Dec 28, 2005 7:14 pm

Mace I too have recently bought the IR3 and are now very concerned about the way Naturalpoint have fobbed your reasonable request to get version 4 as compensation for a early defect in your unit. I hope they come good with a bit more consideration as I am sure like myself others too would shy away from them, if considering service differentials in the market place...Note to Naturalpoint - Please do the right thing and show your true support as we all would expect it to be to bolster our loyalty!!!

[ December 29, 2005, 02:20 AM: Message edited by: Ajax ]
Ajax
 
Posts: 1
Joined: Thu Dec 29, 2005 5:00 am
Location: Australia

by EB » Sat Feb 25, 2006 11:48 am

Hello,

Another USB Device problem here. RegFix doesn't find a device either. Red lamp is on (!). Seems to almost work if I install ver. 3 softaware first, followed by ver. 4. In some cases, it even installs the device fine, and it shows up in device manager as TrackIR, but neither version of the software recognizes the device once I open them.

[ February 25, 2006, 06:49 PM: Message edited by: EB ]
EB
 
Posts: 1
Joined: Sat Feb 25, 2006 5:00 am
Location: Los Angeles

by Xpendable » Sat Mar 18, 2006 12:44 pm

After working for a year, my TrackIR has stopped working. Now my computer crashes after you click on the "Continue Anyway" during the driver install. Yikes. This also leaves my Game Controllers control panel in an unusable state. Now that control panel crashes. Any game that I try to load that uses DirectX will now crash also. I just did a complete hard drive format and did a fresh install of XP w/ SP2 and all updates. Went to install the TrackIR software and got the same thing... crashed & rebooted during driver installation. Very frustrating to be working on this problem for an entire week with no progress.
Xpendable
 
Posts: 6
Joined: Mon Jan 10, 2005 5:00 am

by spetz_159th » Wed Mar 22, 2006 4:56 am

Hello there. Kinda the same problem here. My 3pro stopped working altogether on one computer, so tried it on the other, same problem. Program installs fine, but when I connect the 3pro to a USB, it says "USB device has malfunctioned. Windows cannot detect the USB Device.". I have used the NPregfix.zip, and it says there is no problem with the device. I am not going to format my HD just to get it to work. I have uninstalled / reinstalled several times, and tried all 6 USB's on my comp to no avail. Any ideas ?

XP pro SP2, USB Devices - X45, MX 1000 mouse, Printer/Fax.
spetz_159th
 
Posts: 4
Joined: Tue Mar 21, 2006 5:00 am

by gustavm » Mon May 08, 2006 1:32 am

Hi,
Symptoms described sound suspiciously like my own which has proved to be yet another hardware failure, the second TrackIR I have had fail in just over three years!
Regards,
Gustav.
gustavm
 
Posts: 9
Joined: Wed Sep 15, 2004 5:00 am
Location: Devon UK.

PreviousNext

Return to TrackIR 1-3 & Vector Expansion