Track IR 3 does not find hardware driver

Redneck-Pete
Posts: 3
Joined: Wed Jan 19, 2005 5:00 am

Re: Track IR 3 does not find hardware driver

Post by Redneck-Pete » Fri Jan 21, 2005 5:19 pm

Wayne,

Thanks for the help. Worked like a charm.

Drbob
Posts: 7
Joined: Sat May 29, 2004 5:00 am
Location: Zoetermeer, Holland

Re: Track IR 3 does not find hardware driver

Post by Drbob » Sun Jan 30, 2005 10:11 am

Having this problem again... Last time I solved it by reinstalling XP, but I'll try the other solution this time... I hope the reg fix works for me too...
Awaiting an answer to my e-mail

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Track IR 3 does not find hardware driver

Post by Wayne » Mon Jan 31, 2005 6:39 pm

Drbob,

You should have what you need now.
If you have any problems with the registry edit please let me know, I will happy to talk you through this.

Drbob
Posts: 7
Joined: Sat May 29, 2004 5:00 am
Location: Zoetermeer, Holland

Re: Track IR 3 does not find hardware driver

Post by Drbob » Mon Jan 31, 2005 11:40 pm

It's working great now, thanks a lot!

Like I said in the mail, I hope you can find a solution to solve this without having to address everyone individually. Sounds like you're the only person in the world who knows how to solve this right now

EDIT: One question thoug: am I missing something by using the 3.13 drivers like you told me to? Or are the USB drivers included in the 4.0.021 the same?

[ February 01, 2005, 09:20 AM: Message edited by: Drbob ]

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Track IR 3 does not find hardware driver

Post by Wayne » Mon Feb 14, 2005 8:03 pm

Drbob,

1) Ensure that you have version 3 installed.

2) Carry out the install for version 4 and UNCHECK the box for USB drivers. You already have these installed from version 3, so no need to install them again, this will then allow you to keep the custom settings that you made.

3) You should now have two icons on your desktop, one for version 3 and one for 4. Both versions will now work on your system.

If you have any problems please let me know.

Sema_4
Posts: 1
Joined: Wed Feb 23, 2005 5:00 am
Location: Scotland, UK

Re: Track IR 3 does not find hardware driver

Post by Sema_4 » Tue Feb 22, 2005 11:03 pm

Hi

I have had my TrackIR 3 Pro for... a long time.. I have never had a problem with it until 2 weeks ago when it was not responding properly in a game and when I checked, it had a full green screen as some others have reported here. I unplugged it and connected it again and all was well.

About a week later I was playing a game and I heard the sound you get when you unplug a USB device, and ever since then my TIR3Pro has not been recognised. After a reboot I get the sound when I plug it in, and it says FOUND NEW HARDWARE - USB DEVICE, although sometimes it will say 'UNKNOWN DEVICE'.

My serial no is 017195.

I just added Vector Expansion to this about 4 weeks ago, is this related ?

HELP ! Please ? Thanks !!

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Track IR 3 does not find hardware driver

Post by Wayne » Wed Feb 23, 2005 7:03 am

Sema_4,

I need a copy of your setupapi.log, so we can see what may be happening with the install.

urs.schneider
Posts: 2
Joined: Wed Feb 23, 2005 5:00 am
Location: Switzerland

Re: Track IR 3 does not find hardware driver

Post by urs.schneider » Wed Feb 23, 2005 9:18 pm

Hi everybody

Just want to let you know, that my new TrackIR 3 pro is not recognized by my computer (same problem as described in several posts here). I tried on several machines with different OSs (Win XP home with or without SP2, Win XP Pro, Win 2K), different manufacturers. Sometimes it worked, sometimes not (about 50:50).

I have connected many many different USB-devices to my and many other computers in the last years, never had a this or a similar problem.
Where is that bug sitting??

Barred
Posts: 881
Joined: Mon Mar 17, 2003 5:00 am
Location: Scotland

Re: Track IR 3 does not find hardware driver

Post by Barred » Wed Feb 23, 2005 11:02 pm

Ursus, If you are using XP or W2K, then give this a try if you have had a few things plugged in and out of your USB.

Plug your mouse into the USB that you want to use your TIR in. This will check the USB port as hte mouse has priority over every device except for the keyboard.

Uninstall your TIR and remove the directory (C:\Windows\Program files\Natural Piont is the default).

If your mouse is working, we can rule out a faulty USB. Now for the next part it is a good idea to have your system disk.

Download the latest driver (if you have not already) for your TIR.

Open up Divice Manager (right click on 'My Computer' and goto 'Properties'.

Open up 'Universal Serial Bus' and delete all instances that pops up. Once you have done that then remove the main USB it's self.

Reboot.

Now you should hear a load of beeps (whe connection/disconnection double beeps.) this is XP/W2K rebuilding the USB Tree. This is where you might need your system disk.

You might need to reboot a coupe of times to get them all.

Once you can reboot with out any 'found new hardware' beeps or displays. Install the latest TIR driver.

Conect your TIR after the drivers have been found and folow the prompts.

This will give you a fresh install of TIR ontop of yout new USB tree.

The above is taking that you have the larest motherboard driver (intel and for VIA ect).

With the TIR unit about 30-36"(90-95cm) and about 2"(5cm) above where you naturally sit and have your reflector(s).

Hopefully that will work. If not feel free to pm me your DXDiag and setupapi.log.

Good Luck

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Track IR 3 does not find hardware driver

Post by Wayne » Thu Feb 24, 2005 10:20 am

Ursus,

If you have not already sent me your setupapi.log please do so, then we can see what may be the problem with your unit.

Post Reply