Track IR 3 does not find hardware driver

Post Reply
jimrad1
Posts: 5
Joined: Thu May 27, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by jimrad1 » Wed Jun 02, 2004 5:52 pm

quote:Originally posted by Wayne:
Jimrad1,

Please e-mail me with your details and I will ensure that I have your serial number in our database.

ThanksDisregard Wayne, after installing it on two different systems in safe mode and windows98 compatiability mode, both systems are working now. 2 days and not so much as a hiccup. Both systems are obviously WindowsXP Pro platforms.

Will keep you posted.

jim

[ June 03, 2004, 12:53 AM: Message edited by: jimrad1 ]

jtchris
Posts: 11
Joined: Mon May 24, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by jtchris » Thu Jun 03, 2004 4:46 am

Hey Wayne -

I just realized that I can't really send you my hard drive for repro'ing-debugging, they are RAID 0'd together, so you'd need identical RAID hardware, etc., and of course since it's 0 and not 1, I can't send you just one. Great.

I'll take a look at the reg keys when you send them and see if I can detect what the issues are. Hmm ...

Thanks,
Jeff

Topace
Posts: 12
Joined: Thu Jun 03, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by Topace » Thu Jun 03, 2004 7:38 am

Hi all!

Good to see that I'm not the only one with this problem. Today i recieved my new TrackIR 3 Pro. I never used any TrackIR before. After doing exactly what the Installation Guide has told me, i get an "USB Device" after pluging the TrackIR in. But the System does not find the driver, not on the CD nor in Windows\Inf or Windows\system32. (Driver Ver. 3.10)

I tried to install in safe mode without success. Hoping that this problem will be solved soon.

BTW: When trying to uninstall & then reinstall the Software, it tells me that a Registry key ("Enum/USB/Vid_131&Pid_0155" could not be deleted... tried to erase it directly with regedit, but without success - even in safe mode).

My Specs: Win XP Pro with SP1 & all the Patches; Asus a7n8x deluxe (but tried also to get trackir to work with an usb-pci-card);

I have the following other usb-devices currently connected to the computer (also tried without those connected): microsoft sidewinder precision 2.
other usb-devices sometimes connected to the computer are: casio excilim craddle; Creative MuVo mp3-player; external HDD (one from WD and another from ibm).

Perhaps it has something to do with "too much" usb-things that were connected? Something like "registry overflow"? Or with too much usb-controllers/ports?

I hope this helps. And sorry for my bad english, but i tried my best

/edit: well, the exact same problem as it is here:
http://forums.naturalpoint.com/cgi-bin/ ... 2;t=000153
(only without previous trackir installed...)

[ June 03, 2004, 03:02 PM: Message edited by: Topace ]

jtchris
Posts: 11
Joined: Mon May 24, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by jtchris » Thu Jun 03, 2004 8:04 am

I also tried plugging into different USB ports - powered, unpowered, on the motherboard, on a hub, whatever - it didn't matter. I have loads of other USB devices, I could try taking some of those off ...

Looks like wiping the machine and starting over fixes it, which means that either XP is getting in a funky state (e.g. the registry explanation, going with what Wayne and crew currently think) or all affected folks have an issue with a certain piece of software that we've installed.

Wonder if it's worth doing registry captures or Add/Remove Programs capture and sending in to Wayne to look at - might find the common thread?

-Jeff

Topace
Posts: 12
Joined: Thu Jun 03, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by Topace » Thu Jun 03, 2004 8:16 am

Hm well...

can anybody confirm that trackir works after a clean reinstall of windows xp?

if it is so, then something must get "overfilled"... an incompatibility with another programm is very unlikely, since the installation doesnt even work in safe mode, where most other procedures are not running...

jtchris
Posts: 11
Joined: Mon May 24, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by jtchris » Thu Jun 03, 2004 12:35 pm

I have a clean install of Windows Server 2003 and TrackIR installed just fine a couple of minutes ago (btw - cool!). I'm doing diffs between the registry - some very odd diffs in the USB enumeration tables. Definitely the problem, but not sure why it's happening ...

Wayne, I've forwarded registry access calls (made with RegMon) from both install and when the device is first plugged in. I also sent along the .reg file for my USB enumeration hive.

Hope this helps ... we're getting there ...

-Jeff

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Track IR 3 does not find hardware driver

Post by Wayne » Thu Jun 03, 2004 2:56 pm

Thanks Jeff,

They arrived as I left, I will have a good look at these tomorrow.

Thanks again.

Topace
Posts: 12
Joined: Thu Jun 03, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by Topace » Thu Jun 03, 2004 4:56 pm

Ah, I think this is near to a solution for the problem

As soon as you find out something, please let us know - even if it is something "difficult" like some regediting-action or etc...

Perhaps it would help if someone with wxp pro and trackir3 who's doing fine would post me his registry entries, so i could alter mine to "working" values, or at least compare it.

Topace
Posts: 12
Joined: Thu Jun 03, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by Topace » Fri Jun 04, 2004 9:21 pm

I just managed to delete these Registry keys... (right click and then give permissions to all users, then you can delete it)

But still not working... im trying a bit more...

/edit

Can someone with a working trackir3 and winxp PLEASE send me his registry dump from HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\Vid_131d&Pid_0155

/edit2

Just tested on the pc of my brother - same win xp pro... there it works! i copied the registry entries to me. Now i have the trackir in the control panel, but with a yellow "!" on it... says he cant find the driver. when i try to reinstall the driver, he does not find one.

/edit3

Now also copied driver information from the registry of my brother into mine... but something is still missing (error code 19)

/edit4

if someone would just tell me all registry entries of a working trackir3 installation then i could alter these, so that the trackir works on mine, too... but some entry is missing and i dont know which one...

What i did:

1. clean correct install of the driver software

2. Doing manual reg entry:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_131d&Pid_0155]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_131d&Pid_0155\5&2ead4a20&0&2]
"DeviceDesc"="NaturalPoint trackIR 3"
"LocationInformation"="USB Device"
"Capabilities"=dword:00000004
"UINumber"=dword:00000000
"HardwareID"=hex(7):55,00,53,00,42,00,5c,00,56,00,69,00,64,00,5f,00,31,00,33,\
00,31,00,64,00,26,00,50,00,69,00,64,00,5f,00,30,00,31,00,35,00,35,00,26,00,\
52,00,65,00,76,00,5f,00,30,00,30,00,30,00,31,00,00,00,55,00,53,00,42,00,5c,\
00,56,00,69,00,64,00,5f,00,31,00,33,00,31,00,64,00,26,00,50,00,69,00,64,00,\
5f,00,30,00,31,00,35,00,35,00,00,00,00,00
"CompatibleIDs"=hex(7):55,00,53,00,42,00,5c,00,43,00,6c,00,61,00,73,00,73,00,\
5f,00,66,00,66,00,26,00,53,00,75,00,62,00,43,00,6c,00,61,00,73,00,73,00,5f,\
00,30,00,30,00,26,00,50,00,72,00,6f,00,74,00,5f,00,30,00,30,00,00,00,55,00,\
53,00,42,00,5c,00,43,00,6c,00,61,00,73,00,73,00,5f,00,66,00,66,00,26,00,53,\
00,75,00,62,00,43,00,6c,00,61,00,73,00,73,00,5f,00,30,00,30,00,00,00,55,00,\
53,00,42,00,5c,00,43,00,6c,00,61,00,73,00,73,00,5f,00,66,00,66,00,00,00,00,\
00
"ClassGUID"="{36FC9E60-C465-11CF-8056-444553540000}"
"Class"="USB"
"Driver"="{36FC9E60-C465-11CF-8056-444553540000}\\0011"
"Mfg"="NaturalPoint"
"Service"="NPUSB"
"ConfigFlags"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_131d&Pid_0155\5&2ead4a20&0&2\Control]
"ActiveService"="NPUSB"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_131d&Pid_0155\5&2ead4a20&0&2\Device Parameters]
"ExtPropDescSemaphore"=dword:00000001
"SymbolicName"="\\??\\USB#Vid_131d&Pid_0155#5&2ead4a20&0&2#{a5dcbf10-6530-11d2-901f-00c04fb951ed}"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_131d&Pid_0155\5&2ead4a20&0&2\LogConf]

3. Doing manual reg entry:

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}\0011]
"InfPath"="npusb3.inf"
"InfSection"="NPUSB"
"InfSectionExt"=".NT"
"ProviderName"="NaturalPoint"
"MatchingDeviceId"="usb\\vid_131d&pid_0155"
"DriverDesc"="NaturalPoint trackIR 3"

4. Same as 3. but also in the keys "CurrentControlSet" and "ControlSet003"

What else must i add to have all reg-entries completed?

[ June 05, 2004, 06:22 AM: Message edited by: Topace ]

Topace
Posts: 12
Joined: Thu Jun 03, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by Topace » Sat Jun 05, 2004 3:01 am

Ok I surrender...

i did the exact same registry entries as on a working installation - without success (device manager says code 19 ""Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)")

If I do a normal, fresh install, windows does only recognize an "usb device" and cant find a driver, even if i point to npusb.inf...

I'm looking forward for a fast solution for this problem. Reinstalling windows xp isnt an option.

Post Reply