Track IR 3 does not find hardware driver

Post Reply
Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Track IR 3 does not find hardware driver

Post by Wayne » Tue Jun 08, 2004 1:33 pm

Thanks Topace,

We are just looking through it at the moment.
I think it may be wise just to hang on a little while, it would be a little daunting for some users I'm sure.

After we have had the chance to test it, there may be the chance that we could work with it during the install routine.

As you know I have tested it myself in Virtual Machine and on my home computer with no problems, so I can say this is looking very promising.

uehawk
Posts: 4
Joined: Mon Jun 07, 2004 5:00 am
Location: England

Re: Track IR 3 does not find hardware driver

Post by uehawk » Tue Jun 08, 2004 5:45 pm

after reading all those post above....O hell!! have i done the right thing in spending all this money.
good luck everyone
uehawk

jtchris
Posts: 11
Joined: Mon May 24, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by jtchris » Wed Jun 09, 2004 4:10 pm

Hooray!

Hooray!!

Hoorraaaaay!!!

That did the trick, Wayne - thanks everybody who banged on this!!

Oddly, I had a hard time applying one of the .reg patch files - the first one only (the second and third went on fine). It said that the system was using it or another process was using it. I finally figured out that I had to select the USB reg key root and set Permissions such that all users could set ... interesting. Perhaps this is why the install failed the first (and second and third ... ;-) time?

Anyway ... good stuff! I just landed my Grumman Goose on some mountain lakes and buzzed St. Helens in a Piper - and now I'm motion sick! Awesome!

Thanks again, everybody!
-Jeff

ncleme
Posts: 1
Joined: Sun Jun 20, 2004 5:00 am

Re: Track IR 3 does not find hardware driver

Post by ncleme » Sun Jun 20, 2004 7:46 am

Any chance of getting the prized information as to getting TrackIR3 pro to work on XP. I too have a problem with the USB...

Please Please Help!!!!!

Cap
Posts: 1
Joined: Mon Jun 28, 2004 5:00 am
Location: Germany

Re: Track IR 3 does not find hardware driver

Post by Cap » Mon Jun 28, 2004 2:38 am

Dear Admin,

on friday I got my TrackIR-3 pro and red all information before installing.

My system is:
--------------------------
AMD Athlon 2400XP+
1 GB DDR ram
ASUS_A7V8X-X (VIA-Chipset)
NVIDIA Geforce 4 Ti 4200
Soundblaster Audigy
Windows-XP prof. with all patches.

It worked well until I switched my computer off.

After this all happend as writers above have allready mentioned:

- problems with de-installation, I had to work manually on the registry,

- could install a second time - again all fine until power of on the pc and nothing could be done after.

What is most important: even after manually cleaning all parts of the registry I couldn't install again.

A try on my labtop with centrino-technology (which is: intel chipset all over) didn't work at all.

Sorry to say : your product is extremly well build and usefull, but your installer is not.

All things I could try reasonably I have tried.
Even a restore point rollback to a day before the TrackIR arrived didn't work to get the thing running again.

I work myself on computer, network and programming - so problems are a thing I simply try to solve.
So please give me a bit of aid.

I am willing and able to do the settings on the registry ( naturly on my own risk ) - just send me a mail with the settings and will report after.

Edit: I tried new VIA drivers 4in1 and for usb2 and soundblaster dirvers as well - no success.
The manual editing for registry as far as I could see from the earlier postings was without success.

@ Wayne or Administrator of this forum:
Please post something which shows you read what we are trying to get to your attention - and if possible give a solution.

Help is really apreciated after spending lots of hours (I am working man who has not much free time left) this will at least give us a less bad feeling - thanks....

[ June 28, 2004, 02:33 PM: Message edited by: Cap ]

Nexus
Posts: 1
Joined: Mon Jun 28, 2004 5:00 am
Location: Greece

Re: Track IR 3 does not find hardware driver

Post by Nexus » Mon Jun 28, 2004 7:15 am

I have the same problem with all this people, i use Win Xp pro Sp1.

My trackIR is coming today and after many installs finaly i have tha same problem with the Drivers.

I try to conect the TrackIR in another computer with win 2000 pro and is working well.

The problem is only on Win xp, please Help.

Thanks

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Track IR 3 does not find hardware driver

Post by Wayne » Mon Jun 28, 2004 8:43 am

Hello Nexus, and Cap,

Nexus I received your e-mail this morning , so i will be answering that too.

Firstly there is more than one reason for the failed install, most of the time this is due to a problem within the registry.

The good news is that I have a registry fix for this, however I have to be sure that your specific problem warrants this particular fix.

After the install has finished and you are left with unknown USB in the Device Manager, I would like you to un-install the unknown device (through the device manager), and then allow system to re-boot. At this time leave your unit connented to the USB port.

After the reboot, allow the hardware wizard to run through the install, if the drivers are not found, then please e-mail me with your setupapi.log file then I will know what registry change we will have to make.

Wayne

stickshaker
Posts: 4
Joined: Tue Jul 06, 2004 5:00 am
Location: Netherlands

Re: Track IR 3 does not find hardware driver

Post by stickshaker » Tue Jul 06, 2004 6:49 am

I also have the problem that the tracker cannot be installed when upgrading to version 3. The tracker software does not install whereas the computer senses that the tracker is connected byt it says the registry is corrupted or damaged. When I try uninstalling the software and use the option to clear all registry data i get the following messages:

unable to remove key system\current control set\enum\usb\wd_05478pid_1002

and

unable to remove key system\current control set\enum\usb\wd_05478pid_2235.

Does this give anyone a clue? For me, re-installing Windows is not an option.

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Track IR 3 does not find hardware driver

Post by Wayne » Tue Jul 06, 2004 8:06 am

Hans,

Can you use the system restore to the point before you installed the software for TrackIR3?

What you will need to do is to un-install the earlier drivers first, if this fails then re-install the earlier drivers first, this should correct the registry.

If you are still having problems then please e-mail me and I will help you with the registry removal.

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Track IR 3 does not find hardware driver

Post by Wayne » Wed Jul 07, 2004 4:59 pm

Hans,

No problem.
Please drop me an e-mail tomorrow and include your setupapi.log file from Windows.

This will tell me a little more about the installs or attempted installs that you have made, and help me to determine what failed.

Post Reply