I think my TrackIR 3 Pro just broke

Post Reply
MattThomas
Posts: 7
Joined: Mon Nov 17, 2003 5:00 am
Location: Kansas City

I think my TrackIR 3 Pro just broke

Post by MattThomas » Tue May 17, 2005 1:20 am

I've used my TrackIR 3 Pro with Vector Expansion for 4 months and it's wonderful...I'll never go back to anything less.

After 4 months of flawless usage, I think my TrackIR 3 Pro broke last night.

* The TrackIR 3 Pro seemed to suddenly lose power. There was no red, green or blue light. Nothing.
* The WindowsXP Professional operating system crashed and wouldn't re-boot. I had to re-boot in safe mode.
* The Device Manager showed no conflicts on the TrackIR 3 Pro.
* I used System Restore and restored it to a time 4 hours earlier when everything worked fine.
* I started the TrackIR software, but it got no data from the TrackIR3 Pro.
* I shut down the TrackIR software, waited 30 seconds, unplugged the TrackIR3 Pro, waited another 30 seconds, plugged it back in and tried the software again. The TrackIR software wouldn't load.
* I tried the TrackIR3 Pro in a different USB port, it seemed to be recognized fine by WindowsXP, but again the TrackIR software application wouldn't start.
* I unplugged the TrackIR3 Pro completely, and then I was able to start the TrackIR sofware.

Is it broken?

I consider the TrackIR3 Pro with Vector Expansion to be absolutely essential for my flight simulator. I made a video demonstration of my simulator at www.RogerDodger.net
Thanks.
Matt Thomas
Matt@RogerDodger.net

MattThomas
Posts: 7
Joined: Mon Nov 17, 2003 5:00 am
Location: Kansas City

Re: I think my TrackIR 3 Pro just broke

Post by MattThomas » Tue May 17, 2005 1:22 am

AND....the serial number on my TrackIR3 Pro is 24253

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: I think my TrackIR 3 Pro just broke

Post by Wayne » Wed May 18, 2005 9:57 am

Thanks Matt, you should have the return info now by e-mail.

Post Reply