Page 1 of 1

Driver error ?

Posted: Sun Oct 20, 2002 2:29 am
by FOG

purchased the TrackIr GX as a bundle with my edimensional 3d glasses. After i upgraded my windows XP, i received an error in my eventwiever, and the mode change button dont work.

Here is a screenshot from my event viewer:

Is this a driver issue, ore is my trackIR broken. Have tried on two different computers, same result.

Pls respond!, miss my head movement in fs2002.


Re: Driver error ?

Posted: Sun Oct 20, 2002 9:05 am
by Halstead York
I would try doing a complete uninstall of the trackIR drivers, download and install v1.22 from our downloads page here, and let us know if that works.

FWIW, the upgrade from win9x to XP rarely goes well. I've had friends at Microsoft actually beg me to do a clean install instead of upgrading. There are more drivers issues with the upgrade than you can shake an IRQ at.

Re: Driver error ?

Posted: Sun Oct 20, 2002 11:14 am
by FOG
Hi again!

Have to explain a bit further, as I was a bit short in my first post.

Have last week reinstalled XP as i changed my motherboard. After installation, the naturalpoint worked OK, After i used windows update, this error occur in my event viewer every time I boot my PC. The Unit works, making the mouse movement as it should, but nothing happens when I try to enable the FS2002 MODE aore the keymapping mode.

Have tried to completely remove and reinstall, resulting in the unit to function OK at initial boot (when the unit is connected, after installing the software), but the next time I boot my PC, the same error occurs in event viewer.

Have also tried the unit on my friends PC, he`s also running XP-pro wit SP1 installed. maybe an servicepack issue ?

I do also have other USB units, and one USB HUB connected, Before version 1.22 I was able to connect the TrackIR in both the HUB and directly into the back om my PC. Now with ver 1.22, plugging the TrackIR into my computer results in my USB-HUB beeing turned off ?.

Anyway, heres my PC-specs, so you have some more details to work with:

AMD XP2200
ECS K7S5A Motherboard with SIS735 chipset
1 GIG DDR ram CL2
Geforce 4-4600 128mb ram
Trendnet USB HUB TU-700
CH products USB yoke and pedals
Omnikey cardman 2020 USB smart card reader
Pioneer DVD
Lite-on CD-burner
19` Samptron monitor

Hope we can find the solution here


Re: Driver error ?

Posted: Sun Oct 20, 2002 12:28 pm
by Jim

It sounds to me like the Windows Update feature tried to find a new version of our driver, which it couldn't and then messed up the USB driver ID signature in the Device Manager. Sometimes you can just remove the device from the Device Manager and do a clean install of our software. I haven't seen this exact problem before, but I must assume that other users have XP with SR1.

I don't think that the driver problem should effect the Mode key at all, try reasigning the key and see if that fixes it.

Worst case you might have to delete all registry entries to our device, which I can give you the keywords to search for. This is a last resort of course.

Re: Driver error ?

Posted: Sun Oct 20, 2002 3:56 pm
by BlitzKrieg
Just for your info Fog I have XP Pro and the SP1 no problems on my end. I hope u get it figured out.

Re: Driver error ?

Posted: Sun Oct 20, 2002 5:52 pm
by FOG

Reassigning the key doesnt help at all, Neither does a complete uninstall.

Maybe you have info what keys that are added into registry?. If you do, I will try to delete them manually, and reinstall software.

the EZMON.SYS error affects the driver loader, and it seems from the event-viewer that the system cant find any devices attached to it.

The EZUSB.SYS is attached to the software as well (naturalpoint tracker), and this works.

Brad, maybe you can tell me the version name of theese two files, (they are located in windows\system32\drivers), and what chipset does your motherboard have ?

Some says the SIS USB drivers are to blame, but the TrackIR have worked on my system before. It stopped working after I ran one of the critical updates in windows-update. Have not ran any driver update that should affect this.

I am beginning to believe my track IR is faulty, as no one else have this problem. good that warranty is still valid. Whom do I contact in case of warranty issues ?

Well, I am awaiting your posts, we will solve this issue, I am sure!


[ October 21, 2002, 12:55 AM: Message edited by: FOG ]

Re: Driver error ?

Posted: Mon Oct 21, 2002 4:37 am
by BlitzKrieg
ok here u go...

ezmon version

ezusb version

Asus A7A 266 w/ ALI chipset (latest drivers from ali, not sure of version number)

Let me know if u need anything else.

Re: Driver error ?

Posted: Mon Oct 21, 2002 6:27 am
by FOG
Hi brad!..

Yeah, same version as mine.

Still gets same error, works at initial boot after installation, then next time i reboot, the error in event viewer occurs, and MODE button dont work.

Strange this,.. any1 have any idea at all whats causing this ?


Re: Driver error ?

Posted: Tue Oct 22, 2002 3:38 pm
by Jim

This is a strange one for sure. I think that it must be trying to reinstall itself or do some sort of self updating, not good.

Can you use the System Restore feature to go back in time before the Critical Upgrade? This might take things back to the way they were, which would be good at this point.

To delete the trackIR completely, which we have only done in Win2K, you must do the following:

Have device plugged in, delete from Device Manager. Unistall our software. Run Regedit and delete everything with the following in it: NaturalPoint, Eye Control Technologies, Pid_2235, Pid_1002, EZUSB, EZmon

That should do it, restart and then install our software, then install the device, it should seem like the computer is finding it for the first time, if it doesn't run you through the "new device found" proceedure, like it did the first time then we didn't get all the entries. Make sure it shows up properly in the Device Manager and then try it out.

Let us know.

Re: Driver error ?

Posted: Wed Oct 23, 2002 1:17 am
by FOG
Hi Jim!

Did what you described, and now its working!!!!

Had problems to delete the "Pid_1002" and "Pid_2235" entries in registry, but by changing the permission to the folder (in registry) I finally managed to delete them.

The error in event viewer still occurs, but the device is working without errors, guess it has nothing to say anyway.

After some investigation, I found out that a critical update in windows changed the device id, in the PiD_xxx sections, and as theese where read only, it wasnt removed at software uninstall, beeing an error that wasnt removed regardless of the TrackIR and software was installed ore not

But now I am happy!!

Thx alot for your service, truly appreciate it!


[ October 23, 2002, 08:20 AM: Message edited by: FOG ]