Page 1 of 2

No device detected

Posted: Thu Apr 14, 2011 5:56 am
by dehart
I'm using TrackIR5.
Today I downloaded the newest version 5.1.300 (build 9945).
After having installed this version and started up TrackIR it does not detect my device!!??
The same for version 5.1.200 (build) 9414).
But installing version 5.0.300 (build 6225) then it works fine!
Device nr. #127382.
OS: Windows 7, 64bit
What is going wrong?

Re: No device detected

Posted: Fri Apr 15, 2011 3:10 pm
by NaturalPoint - Mike
Try uninstalling, re-downloading, then right clicking on the installer and selecting "Run as administrator" This issue is known to occur on some Windows 7 systems due to Windows UAC. Even if your account is an administrator, selecting "Run as administrator" will allow the program to run with elevated permissions and install properly.

Re: No device detected

Posted: Sun Apr 17, 2011 1:09 am
by dehart
Has done as your adviced. UAC was minimum.
But no solution for this problem!
Do I need to install a separate driver for it?
Is there something more I can do (I hope so)?

Re: No device detected

Posted: Sun Apr 17, 2011 7:18 pm
by MitchM
Hi Jos,

I had exactly the same problem.

This is how I got it working...

Unplug trackir device.
Uninstall trackir software.
Reboot your computer.
Install latest trackir software.
Reboot computer again and plug in your trackir device and you will see windows detecting it and installing drivers.
Then you good to go.

Hope that helps

Re: No device detected

Posted: Mon Apr 18, 2011 10:57 am
by dehart
Hoi MitcM,

Thanks very much for your solution.
Now it works perfect!!


Re: No device detected

Posted: Tue Apr 19, 2011 7:12 pm
by MitchM
Good to hear you got it working. :)

Re: No device detected

Posted: Sun May 15, 2011 3:52 pm
by Sons_of_Series
Hi MitchM,

Same problem and your solution worked wonderfully. Thanks!!

Sons Of Series

Re: No device detected

Posted: Sat Nov 10, 2012 8:33 pm
by DarkMellie
I have the same problem but unfortunately Mitch's solution hasn't worked. Been a while since I used TrackIR (stupid babies!) but it was last installed on my Win7 OS SSD which died, replaced by a brand new Win8 OS SSD.

No lights are coming up on the Track IR (before and after following Mitch's instructions), I can't remember if it's meant to. I did get the 'detecting unknown device' thing and then a warning flashed up but due to various other things popping up after start-up, I didn't get time to read the message (unsure if this is stored anywhere?)

TrackIR app is showing 'device not detected'.

OS: Win8 x64
Driver: 5.1.3

I'd appreciate any support you guys can offer :)

Re: No device detected

Posted: Mon Nov 12, 2012 11:40 am
by jolsonsalem
With Windows 8 you'll want to use version 5.2 Beta 2. Unplug your TrackIR, uninstall the software you have now, install 5.2 Beta 2, and then plug the TrackIR back in. Let me know if that helps. ... nuals.html

Re: No device detected

Posted: Mon Dec 17, 2012 4:42 am
by DarkMellie
Forgot to come back and say that this totally worked and my TrackIR is up and running. Thanks a heap, Jeff :)