Win 10 Creators update

This is the place for comments, criticisms and even the occasional compliment related to the SmartNav drivers and profiler. Also the place to discuss and review support issues.
Post Reply
AusQuad
Posts: 3
Joined: Mon Jul 02, 2018 11:23 pm

Win 10 Creators update

Post by AusQuad » Mon Jul 02, 2018 11:58 pm

Hi,

I have been using my SmartNav 3:AT since 2004 and have had very few issues running it on Windows XP, Windows 7 and even Windows 10.

However, I have upgraded my laptop twice to the Creators update & have had to roll it back to the previous build because my cursor was lagging terribly in games & sometimes on the desktop.

I have deliberately disabled windows update in services but am kinda worried about the impending security risks that this entails.

I'd like to know whether other users have had this issue with the creators update. I know that a quick search for mouse lag and creators update has multiple articles about the Xbox game bar utility and so on.

I want to have my PC up to date, but not if it causes my mouse to be glitchy & games unplayable.

I hope someone can help with this issue, any replies are welcome.

Cheers.

Chris.Johnson
NaturalPoint Employee
NaturalPoint Employee
Posts: 120
Joined: Tue Aug 15, 2017 1:56 pm

Re: Win 10 Creators update

Post by Chris.Johnson » Tue Jul 03, 2018 1:43 pm

Thank you for using SmartNAV and contacting us. This is a common problem with Windows 10. You will want to lower the Mouse Override Delay to 0.0. It's located in the Smart NAV Control Panel under the Behavior tab as pictured below.

Please let me know if this helps, or if I can clarify anything further.
Attachments
mouse override.png
mouse override.png (37.44 KiB) Viewed 2093 times
All the Best,
Chris Johnson
Customer Support Engineer
NaturalPoint

umkasanki
Posts: 1
Joined: Sat Jun 29, 2019 4:56 am

Re: Win 10 Creators update

Post by umkasanki » Sat Jun 29, 2019 5:00 am

Chris.Johnson wrote:
Tue Jul 03, 2018 1:43 pm
Thank you for using SmartNAV and contacting us. This is a common problem with Windows 10. You will want to lower the Mouse Override Delay to 0.0. It's located in the Smart NAV Control Panel under the Behavior tab as pictured below.
Thank you very much for your answer.
the problem has disappeared!
Finally, the device again worked fine!

Strela_999
Posts: 26
Joined: Sat Feb 23, 2019 8:22 am

Re: Win 10 Creators update

Post by Strela_999 » Sun Jul 28, 2019 5:02 am

Thanks for the heads-up, I just bought a new computer that runs on Win10 and got stuck... niw it's fine!

MarkcusD
Posts: 2
Joined: Wed Aug 07, 2019 11:52 am

Re: Win 10 Creators update

Post by MarkcusD » Wed Aug 07, 2019 4:43 pm

I was struggling with this as well. Thanks.

bzuidgeest
Posts: 2
Joined: Tue Sep 22, 2009 11:38 pm

Re: Win 10 Creators update

Post by bzuidgeest » Wed Aug 28, 2019 5:22 am

I had this as well, but only when specific programs like skype and asg remote desktop were in focus. Setting the delay to 0 worked. But is there any explanation why this works? what changes?

Post Reply