Dwell clicking software doesn't click in some windows

This is the place for comments, criticisms and even the occasional compliment related to the SmartNav drivers and profiler. Also the place to discuss and review support issues.
Post Reply
NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Dwell clicking software doesn't click in some windows

Post by NaturalPoint - Mike » Thu Jul 19, 2012 11:16 am

Hello -

I have not seen this type of behavior with Windows 7 yet. Are you running the Aero (glass) interface? If so, does it work properly if you switch to a basic theme?

Franck Dernoncourt
Posts: 55
Joined: Mon Apr 02, 2012 1:48 pm
Contact:

Re: Dwell clicking software doesn't click in some windows

Post by Franck Dernoncourt » Thu Jul 19, 2012 3:38 pm

I use the basic theme. Actually, it works fine under my computer running Windows 7 SP1 and my computer running Windows XP (sorry, I should have checked it earlier). So I begin to wonder if the issue isn't "specific" to the main computer I use (which run under Windows 7, no SP1). Maybe an interference with another software I have installed or Windows which begins to get crazy (although there is no other sign of it). Any idea welcome! But I'm happy to know that usually it works, all the more so I am moving soon and will get a new computer, i.e. everything should be okay there :)

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Dwell clicking software doesn't click in some windows

Post by NaturalPoint - Mike » Thu Jul 19, 2012 4:02 pm

It's possible that it's computer specific. Fully updating windows as well as your hardware drivers may help, if that doesn't work you may want to try a reformat/install.

Franck Dernoncourt
Posts: 55
Joined: Mon Apr 02, 2012 1:48 pm
Contact:

Dwell clicking software doesn't click in some windows

Post by Franck Dernoncourt » Fri Jul 20, 2012 4:57 am

Here is the biggest issue I face when using SmartNAV's dwell clicking software in Microsoft Windows 7: in some windows, it doesn't click.

For example, if I open the device manager (Control Panel -> Device Manager), the dwell clicking software isn't able to send mouse clicks in the device manager window (although the computer mouse is able to send clicks). Any idea how to solve this issue?

Thanks for your help,
Francky

Franck Dernoncourt
Posts: 55
Joined: Mon Apr 02, 2012 1:48 pm
Contact:

Re: Dwell clicking software doesn't click in some windows

Post by Franck Dernoncourt » Mon Jul 23, 2012 7:21 am

I have found the roots of the issue: Windows user privileges.

Solution:
Simply run the dwell clicker and SmartNAV as administrator. (yes, also SmartNAV because in the windows where I couldn't click most of the time I couldn't move the mouse cursor neither).

Test:
Open the Windows task manager. As soon as you tick the box "show processes from all users" you will (may?) need have admin privileges to be able to move the mouse cursor and click when the Windows task manager has the focus.

About customized profiles:
When SmartNAV is run normally, profiles are saved in C:\Users\admin\AppData\Local\VirtualStore\Program Files (x86)\NaturalPoint\SmartNAV\Profiles ; when SmartNAV is run as administrator, profiles are saved in C:\Program Files (x86)\NaturalPoint\SmartNAV\Profiles. This means that if you run SmartNAV as administrator for the first time you will not see your customized profiles unless you move the *.xml files in the right folder (i.e. from the first to the second one). The reason why they are two distinct folder is twofold 1) one needs admin privileges to write in C:\Program Files (x86)\NaturalPoint\SmartNAV\Profiles unlike the other folder 2) this latter is specific to one user.

There is one last thing I don't understand: the user profile I'm using Windows have administrator privileges. http://img12.imageshack.us/img12/872/winadmin.png ; I therefore don't understand why everything works fine on my other computers (Windows 7 SP1 ultimate; Windows XP SP3 professional) while it doesn't work on my main computer (Windows 7 ultimate)... maybe the Windows 7 SP1 fixes something. And Windows XP doesn't have http://en.wikipedia.org/wiki/User_Account_Control

However I would be surprised to be the first one to have had this issue. For my experience, each time I get f***ed by Windows user privileges, I am definitely not the only one. Among other things I'm thinking about Windows Vista users ;)

Now the only the remaining issue is mouse lag http://forum.naturalpoint.com/forum/ubb ... #Post52193

Btw it would be great if there was a way to add some kind of tag [solved] in this thread subject (I can't do it because I don't have the option to edit my first post and there is no "solved" button as there are in some forums).

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Dwell clicking software doesn't click in some windows

Post by NaturalPoint - Mike » Mon Jul 23, 2012 11:52 am

You can also try uninstalling, then downloading the installer, saving it to your disk, and running it elevated as admin. The privilege issue generally occurs because windows distrusts it at install, so forcing that trust at install by running the installer elevated generally kills permission issues.


Post Reply