Randomly freezing with Windows 10.

This is the place for comments, criticisms and even the occasional compliment related to the SmartNav drivers and profiler. Also the place to discuss and review support issues.
Post Reply
alsi72
Posts: 2
Joined: Sun Dec 27, 2015 11:54 am

Randomly freezing with Windows 10.

Post by alsi72 » Sun Dec 27, 2015 12:08 pm

Have been using a SmartNav 4 since 2008. It worked brilliantly with Windows XP, and I had no issues with Windows 7 and Windows 8. I found it to be hit and miss with Windows Vista (although I have to admit I didn't persevere and simply switched back to Windows XP).

I can't seem to fathom the problem with Windows 10. It can go for days without a problem, then suddenly the SmartNav just stops responding. There is no pattern. Sometimes the six red LED lights go out as does the green movement indicator at the top, and sometimes it's only the green indicator. I have four SmartNav units, so I know it's not the hardware. I thought it was a power issue, so I plugged in a powered USB hub to run the SmartNav.

Interestingly, starting Skype, stops the SmartNav straightaway, all the time. Needless to say, I've removed Skype for the time being.

Any suggestions please.

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: Randomly freezing with Windows 10.

Post by MikeWitham » Tue Dec 29, 2015 2:50 pm

alsi72,

I have sent this to my Dev to take a look at, but at the moment there is no immediate solution. Have you tried running the software in compatibility with Windows 8? Are you using USB 2.0 or 3.0?

Regards,
Mike Witham
TrackIR Product Manager

alsi72
Posts: 2
Joined: Sun Dec 27, 2015 11:54 am

Re: Randomly freezing with Windows 10.

Post by alsi72 » Tue Dec 29, 2015 3:36 pm

Thanks Mike.

I've been experimenting since I first posted my message. The SmartNav 4 is undoubtedly quite power hungry, so I think my main problem is to do with other USB devices drawing power At the same time. I have been using a USB extender for many years without a problem, but with my new Windows 10 machine this definitely upsets the SmartNav especially when plugged into a PCI card that provides additional USB ports.

Fingers crossed, my problem is now sorted. Using the standard SmartNav 4 cable and connecting directly to a USB port on the motherboard, things seem to have stabilised. No more freezing with Skype switching on web cams, etc, or when I switch on the printer.

Incidentally, I tried using it in Windows 8 compatibility mode, and the lights on the SmartNav were behaving oddly, although the unit itself worked fine.

I definitely think there is an issue with Windows 10 and how it manages power to the peripherals.

I hope this is of some use to other people.

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: Randomly freezing with Windows 10.

Post by MikeWitham » Wed Dec 30, 2015 2:58 pm

alsi72,

Thank you for the in-depth solution and I'm glad to hear that it is working for you now. I will keep this post in mind in case I run into anyone with similar issues.

Regards,
Mike Witham
TrackIR Product Manager

Post Reply