SmartNav not working, not recognizing usb

This is the place for comments, criticisms and even the occasional compliment related to the SmartNav drivers and profiler. Also the place to discuss and review support issues.
Post Reply
Posts: 1
Joined: Sun Apr 09, 2017 5:00 pm

SmartNav not working, not recognizing usb

Post by bababebe » Sun Apr 09, 2017 5:06 pm

I got the smartnav 2 weeks ago, and I used it for a couple of days, and it worked great. I put away my computer for the weekend, and when I wanted to use it again last week, the computer did not recognize the USB device. I tried all ports and 3 different wires. I have a laptop with Windows 10. Any ideas what the issue might be? Can it be similar to the issue that was posted here ... usb#p62196

I was so much looking forward to using this device, and now its sitting on the computer, totally useless... Thanks!

NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: SmartNav not working, not recognizing usb

Post by MikeWitham » Mon Apr 10, 2017 4:16 pm


If you have tried re-installing, moving it to a different USB port, and testing with a different cable, we should look into it more in depth.

If none of those solutions helped, please create a ticket with me at so we can dig deep into the issue, and then fix or replace the device as needed.

Mike Witham
TrackIR Product Manager

Post Reply