SmartNav cursor started sticking after Windows update

This is the place for comments, criticisms and even the occasional compliment related to the SmartNav drivers and profiler. Also the place to discuss and review support issues.
Post Reply
Johnny_F
Posts: 21
Joined: Sun May 13, 2012 5:12 am
Location: London, UK

SmartNav cursor started sticking after Windows update

Post by Johnny_F » Fri Jun 23, 2017 11:53 am

I have just updated Windows 10 with its most recent, major Windows updates (the ones where the computer shuts down and restarts several times). The updates now show Windows Defender with a completely new interface.

Since downloading these updates I have noticed that the SmartNav cursor sticks occasionally whereas it did not do this before the Windows updates were downloaded.

I was wondering whether there was a new SmartNav update to overcome this?

I have tried a few things in the control panel but to no avail.

Has anybody got any idea why this is now happening or a fix to stop it happening?

Do you think I need to uninstall and reinstall the software perhaps?

Thanks

Johnny_F
Posts: 21
Joined: Sun May 13, 2012 5:12 am
Location: London, UK

Re: SmartNav cursor started sticking after Windows update

Post by Johnny_F » Wed Jun 28, 2017 4:00 am

    Please anyone could you help?

    Justgotnav
    Posts: 2
    Joined: Mon Jul 03, 2017 6:24 pm

    Re: SmartNav cursor started sticking after Windows update

    Post by Justgotnav » Mon Jul 03, 2017 6:35 pm

    I'm having the same issue although I just received my smart nav. I'm finding it getting stuck as well sadly I do not know of a fix. I also have Windows 10 hope there is a solution soon.

    Justgotnav
    Posts: 2
    Joined: Mon Jul 03, 2017 6:24 pm

    Re: SmartNav cursor started sticking after Windows update

    Post by Justgotnav » Mon Jul 03, 2017 6:44 pm

    Hey man my friend just was reading the forms and he told me to try this which works for me.

    1. Open SmartNav Settings
    2. Click on the Behavior tab
    3. Adjust the Mouse Override Delay to 0.0 seconds

    Just in case you are still having the issue

    MikeWitham
    NaturalPoint Employee
    NaturalPoint Employee
    Posts: 1477
    Joined: Mon Nov 04, 2013 10:19 am

    Re: SmartNav cursor started sticking after Windows update

    Post by MikeWitham » Thu Jul 06, 2017 3:57 pm

    Justgotnav,

    That has been the best solution so far. Thank you for posting that here.

    Regards,
    Mike Witham
    TrackIR Product Manager

    Johnny_F
    Posts: 21
    Joined: Sun May 13, 2012 5:12 am
    Location: London, UK

    Re: SmartNav cursor started sticking after Windows update

    Post by Johnny_F » Fri Jul 21, 2017 6:46 am

    1. Open SmartNav Settings
    2. Click on the Behavior tab
    3. Adjust the Mouse Override Delay to 0.0 seconds


    Brilliant! Thank you.

    Post Reply