TrackIR 5.4 Software Display Problems on Vista

Post Reply
Flexx
Posts: 3
Joined: Fri Jun 24, 2016 7:16 am

TrackIR 5.4 Software Display Problems on Vista

Post by Flexx » Fri Jun 24, 2016 8:45 am

Hi there,

I have a strange display error in the new TrackIR 5.4.2 release. It appears that all interactive graphical features are not displaying correctly. I have attached a sceenshot showing an empty 3D view, and in the profiles tab, you can see that -- partially -- the content of the Titles tab is still shown after switching to/from it. Seems like these ares simply aren't painted. I also resized the windows to show that the 3D view shows artifacts from other widgets. Does anyone experience similar problems?

I run an older GeForce GTX 280 on the current driver version 341.95 and DirectX 11.

I might add that my trusty old Version 4.1.036 worked fine.

Cheers,
Flexx
Attachments
Screenshot 1 - Artifacts and no graphics displayed.PNG
Screenshot showing artifacts, and disfunctional 3d/graphics areas.
Screenshot 1 - Artifacts and no graphics displayed.PNG (167.05 KiB) Viewed 7168 times

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TrackIR 5.4 Software Display Problems on Vista

Post by MikeWitham » Fri Jun 24, 2016 11:21 am

Flexx,

Would you be able to send me more of your computer specs? Also, what resolution are you running at?

Regards,
Mike Witham
TrackIR Product Manager

Flexx
Posts: 3
Joined: Fri Jun 24, 2016 7:16 am

Re: TrackIR 5.4 Software Display Problems on Vista

Post by Flexx » Fri Jun 24, 2016 2:24 pm

Hello Mike,

thank you for replying so swiftly. I created another attachment with a full dxdiag output, this should contain all the specs.

I am running my desktop at 2650x1600x32.

I might add that my TrackIR 4 Pro + TrackClip device itself works fine with version 5.4.2.

I'll attach another sceenshot showing the screen right after startup. Again, note the missing display in the axis config section and the missing 3d/feedback display.

Cheers,
Alexander
Attachments
DxDiag.zip
Zipped DxDiag.txt
(6.77 KiB) Downloaded 262 times
Screenshot 2 - Display right after starting the application.PNG
Screenshot 2 - Display right after starting the application
Screenshot 2 - Display right after starting the application.PNG (154.08 KiB) Viewed 7156 times

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TrackIR 5.4 Software Display Problems on Vista

Post by MikeWitham » Wed Jun 29, 2016 12:54 pm

Flexx,

What happens if you go into the TrackIR location and delete the Settings.xml file before running the software?

Regards,
Mike Witham
TrackIR Product Manager

Flexx
Posts: 3
Joined: Fri Jun 24, 2016 7:16 am

Re: TrackIR 5.4 Software Display Problems on Vista

Post by Flexx » Sat Aug 06, 2016 3:42 pm

Hi Mike,

I renamed my "C:\Program Files (x86)\NaturalPoint\TrackIR5\Settings.xml" to Settings.xml.bak, as well as my "C:\Users\Flexx\AppData\Roaming\NaturalPoint\TrackIR 5" to "TrackIR 5.bak" and started the application (wich didn't run in that Windows session before).

I get the same behaviour, unfortunately.

What's interesting is that I did not get a new Settings.xml in program files, but a new TrackIR directory appeared in my AppData.

Cheers,
Flexx

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TrackIR 5.4 Software Display Problems on Vista

Post by MikeWitham » Wed Aug 10, 2016 9:53 am

Flexx,

My advice right now would be to remove everything TrackIR. Add/Remove will do most of the work, then manually remove any remaining files from your PC. Reboot and re-install. You shouldn't have Settings in two places and it should re-create it when you close the software. You may even want to go as far as manually removing the NaturalPoint and TrackIR entries in the registry. If you want help with it, or get stuck you can create a ticket with me at help.naturalpoint.com so we can set something up.

Regards,
Mike Witham
TrackIR Product Manager

Post Reply