Page 4 of 4

Re: Trackir 4 pro no device detected

Posted: Thu Feb 05, 2015 2:27 pm
by MikeWitham
Hello danslavibe,

I'm going to fire a few questions at you in hopes to find the cause of the problem.

What does the device show up as in your device manager? Does it do this no matter what port you plug the TrackIR into? Have you tried removing and re-installing the software and drivers? Is everything run as an administrator?

Regards,

Re: Trackir 4 pro no device detected

Posted: Sat Feb 07, 2015 1:23 pm
by danslavibe
Hi MikeWitham,

Thanks to take time for me but after a lot of different tests including one with another computer i have found that's the device worked perfectly on the other computer. I have concuded it was my computer windows installation who was deficient.
So i have decided to reinstall all my windows and since this action it work fine.
In conclusion i haven't find where was the problem and nobody couldn't help me.

Thanks and if i find the heart of the last problem i will answer you.

Re: Trackir 4 pro no device detected

Posted: Fri Jan 08, 2016 1:12 pm
by Grimberg
Hi,

I created account to this forum just for this message.

I have TrackIR 5, and had the same problem, not connecting but windows seeing the device as unknown. Way I got it working was that I played with the drivers.

Here is the step-by-step how I got it working.

Devices and printers ->
TrackIR 5 (Showed, and shows as unknow device)->
Properties ->
Devices ->
Change settings ->
Drivers ->
Update driver ->
Look for driver in this computer* ->
Select driver from computers list* ->
deselect "Show combatible devices"* (IF IT IS NOT SELECTED ALLREADY) ->
Doubletap the device name (in my case TrackIR 5, in your case it might be TrackIR 4) ->
it reinstalls the driver and made it working for me again.
*=I'm using different language OS, so I had to translate the words in my head. I'm sorry if they are not even close.

Hope this helps someone else too.

Re: Trackir 4 pro no device detected

Posted: Mon Jan 11, 2016 3:38 pm
by MikeWitham
Grimberg,

Thanks for the step by step guide.

Regards,

Re: Trackir 4 pro no device detected

Posted: Tue Feb 16, 2016 11:11 pm
by scottclmt
Was this issue resolved? I have the same problem...

recently updated my trackir software to 5.4 and it no longer recognizes my camera. I have checked everything you have mentioned above and cannot work out what the issue is. I have unistalled and tried re-installing an older version based on my serial number (starts 225***) and still nothing. Really keen to get his sorted, its killing my sim time ;P

Re: Trackir 4 pro no device detected

Posted: Wed Feb 17, 2016 1:16 pm
by MikeWitham
scottclmt,

Is it not showing up correctly in your device manager? Or, is it just not working within our software?

Regards,

Re: Trackir 4 pro no device detected

Posted: Wed Feb 17, 2016 1:55 pm
by scottclmt
Hi there Mike,

Thank you for your reply, I managed to sort it out...uninstalled the camera driver, changed the usb port and re-installed the driver. works fine.

regards,
Scott

Re: Trackir 4 pro no device detected

Posted: Mon May 30, 2016 4:42 am
by Rich6270
Hi Guys and Girls,

Just registered to reply to topic,had the same problem Win7 64bit having at first software was closing apon opening saying trackir error shutting down crap.
Lights were all on but nobody home,uninstalled unplugged restart,reinstalled pluggd back in with drivers didnt install properly errors,updated 64bit drivers in device manager on yellow balloon (unknown device),driver installed,no more yellow balloon,unpugged replugged then lost all lights.
Repeated above,restart and still no lights,uninstalled all software,unplugged,restart,reinstalled,plugged back in and still no lights.
Was starting to think i killed the unit so in a last ditch effort done a system restore to when i thought it worked,system restore failed to restore properly no files or folders changed error.
So before i chucked this thing ion the bin i thought i would try and open trackir for the last time and blow me down it come to life,am now thinking system restore must have changed something in the right direction.
Am convinced this is a driver issue,so for all you gamers doing the above over and over again just like i did,inless your trackir just shit itself while you were using it,chances are the your trackir
is still working.
So if someone tells you your unit may be dead when it worked fine before then dont believe them,seems to me it is a driver and windows problem,DONT GIVE UP as the way i fixed my trackir still makes no sence to me.

Re: Trackir 4 pro no device detected

Posted: Mon Feb 05, 2018 1:03 pm
by britrb
I know.. Zombie thread.. But I am having the same issue. Tried camera in multiple USB 3 and 3 ports its not even getting picked up by device manager. No blue light, nothing. This has worked great for years, but last night half way through an Arma 3 mission and the thing stopped working.

Have tried uninstalling, and removing every trace of naturalpoint/trackir from my PC.
Installing different versions from 5.3 up.
Many different USB ports.

Not a clue what to do next. Is there a special prayer to you Oh Great USB Device God? I need TrackIR to work, as I have been spoiled by NaturalPoints awesomeness for far too long. I feel like I have a broken neck if I play without it. It feels wrong :(

Tsch... as I write this post the TrackIR just bonged back on and is now showing in the device manager. I'll save this and post after an attempt at a restart..

Nope, still not working. But it still shows up in Device Manager.

Re: Trackir 4 pro no device detected

Posted: Tue Feb 06, 2018 3:10 pm
by mc_sushi
Hello brltrb,

If the TrackIR comes in and out of the Device Manager, it probably means that the connection is bad. If you haven't tried yet, I would try wiggling around the USB cable to see if you can get the device manager to recognize TIR consistently. If it doesn't show up in the device manager, it will not show up in the TIR software. If it gets disconnected intermittently, it may also fail to get initialized in the software.

I would suggest try using it on a different computer and see if you get the same result. If so, the device or its cable may have just gone bad.

Cheers