NPRegFix.exe - Registry Fix here!

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: NPRegFix.exe - Registry Fix here!

Post by VincentG » Fri Oct 20, 2006 1:20 pm

Sometimes windows gets confused, and changing USB ports causes the system to reinstall the TrackIR.

If it's working, no need to send the info.

TimKuijpers
Posts: 1
Joined: Tue Sep 04, 2007 9:54 am

Re: NPRegFix.exe - Registry Fix here!

Post by TimKuijpers » Tue Sep 04, 2007 10:31 am

I'm getting the same signals as Blodhemn described in his first post.
I have to say that my original trackIR software V4.1.028 started to crash everytime I started it.
So I tried updating, uninstalled the old version and installed V4.1.030.
While at .028 it was saying "no device detected", with .030 it says I have an "Opti track Unkown"
And also my license file is not valid..

I have searched the forum and tried all these basic things like power saving and isolated USB's.
But before it was working well even on an USB hub,

Unfortunately my trackIR didn't fix itself by plugging it into a different USB port.

But about all this product info, I don't know where to find it.
TrackIR sponsored 2 trackIR devices to the Lowlands Cup back in 2006.
I won one of those and I only have got a CD with software, and the TrackIR device.
On the USB cable there is a label with a barcode.

I hope you can figure out what my problem is, and please don't tell me that it's broken..

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: NPRegFix.exe - Registry Fix here!

Post by VincentG » Tue Sep 04, 2007 12:50 pm

Email us directly at support with the following info.

What is the Serial # of the device?
It should be located on the end of the cable, near the USB plug, or on the underside of the device.

Could you send us a copy of the Setupapi.log file?
It should be located in the C:\Windows folder

Have you tried the device on another system?

Are you plugging in directly to the system, or are you using a hub?

Have you tried isolating the device on the USB ports?

Could you attach a screen shot of your device manager, and tracking screen?

To make Print Screen work, you must save an image of what's displayed on-screen to the clipboard and then paste it into a document where it can be printed.

Windows Help: Print Screen

To do this, follow this procedure:

1. Maximize the window you'd like to capture.
2. To copy/capture the current window, hold down ALT + Print Scrn at the same time. To capture the entire screen, just press Print Scrn alone.
3. Open a new document in MS Paint, MS Word, MS Photo Editor, or Adobe PhotoShop.
4. Paste the screen shot by holding down CTRL and V at the same time.
5. Save the document as a .JPG or .JPEG file and send it in.

Have you tried turn off any kind of power save feature for your USB ports?

In the "Device Manager" you can right click the "USB Hub"(s) that show and turn off the power saving feature that turn those ports off when idle. Sometimes that has an impact on the connectivity of the devices.

RHK111
Posts: 1
Joined: Wed Oct 03, 2007 11:42 am

Re: NPRegFix.exe - Registry Fix here!

Post by RHK111 » Wed Oct 03, 2007 2:13 pm

THX Admin,

It fix solve my install problem. I buy my TIR today and with soft from orginal CD (ver. 4.1.030) it was impossible to install it, but after download "4.1.030 Final B" I have been able to do it.
Nice to fly LockON with Track :)

Salu2

tbolt
Posts: 2
Joined: Thu Oct 18, 2007 8:03 am

Re: NPRegFix.exe - Registry Fix here!

Post by tbolt » Wed Oct 31, 2007 7:05 am

i havent gotten my trackir4 working for 2 months- i cant fly without it now, i woulda been better off if i never installed it.
as per your instructions i tried these:

Are you plugging in directly to the system, or are you using a hub? - answer: directly to system

Have you tried isolating the device on the USB ports? -answer:i tried all usb ports -all of my other gaming devices are working on them.
i downloade the registry fix, when i attempt to run it i get a message that no devices are in need of repair. -this was supposed to take care of the original problem that no device was detected.

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: NPRegFix.exe - Registry Fix here!

Post by VincentG » Wed Oct 31, 2007 10:56 am

This is one tool, if you have a registery that is not allowing the device tobe detected.

Have you tried the device on another system?

Have you tried turn off any kind of power save feature for your USB ports?

In the "Device Manager" you can right click the "USB Root Hub"(s), that show, and then select properties. On the power management tab, uncheck the box that allows the computer to turn off the USB port to save power (i.e. uncheck the box). Sometimes that has an impact on the connectivity of the devices.

ChiggyV
Posts: 5
Joined: Fri Jan 11, 2008 6:58 pm

Re: NPRegFix.exe - Registry Fix here!

Post by ChiggyV » Fri Jan 11, 2008 7:08 pm

I recently installed the lastest updates and now my device is dead, no lights and my pc does not see the unit at all. What are my options as I can't afford to buy another.


Oh I tried running the regfix and it does not find a device to fix. But again my pc does not react to it at all. I verified the usb port is working btw.


Thanks

ChiggyV
Posts: 5
Joined: Fri Jan 11, 2008 6:58 pm

Re: NPRegFix.exe - Registry Fix here!

Post by ChiggyV » Fri Jan 11, 2008 7:14 pm

Interesting, I tried it on an old 98 box and the blue and red lights fire up! I've noticed that a couple of MS hotfixes have come down in the last few days and I have seen them do some strange things to pcs. I will test some more.

ChiggyV
Posts: 5
Joined: Fri Jan 11, 2008 6:58 pm

Re: NPRegFix.exe - Registry Fix here!

Post by ChiggyV » Fri Jan 11, 2008 7:21 pm

Ok riddle me this batman LOL! After I plugged it into the old 98 box with usb ports and plugged it back into the xp box the xp box sees it. And its working fine.

So as strange as it sounds the thing is working again by running the regfix without the device plugged in, used the device on another pc long enough to see it light up the device (turned the old box off right after that), I moved it back to the original xp box and it had to reinstall the software for some reason but I get a green light! I think my track ir has had its midlife crisis! ;)


Oh one other small thing, in testing it on the other pc, I had to take it off my vga monitor where it is mounted on the top, anyway the noise from it could have done something as far as maybe causing the signal to be off, yeah its a stretch! I do network support so I dislike the hold your tongue right and its fixed scenario!

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: NPRegFix.exe - Registry Fix here!

Post by VincentG » Mon Jan 14, 2008 12:02 pm

Did you move USB ports?

That have caused Windows to redetect the device within the OS.

Post Reply