FPS Loss

Oracle
Posts: 21
Joined: Thu Jan 19, 2006 5:00 am
Location: New Jersey

FPS Loss

Post by Oracle » Wed Feb 01, 2006 12:57 am

Hi, I didn't notice it so much on the first day I used my new TrackIR4, but now that I took a look at the FPS I was getting out of CFS3 with and without Trackir I was surprised.

With Trackir running minimized (only showing in the tasktray) I am consistently getting 14-20 fps in CFS3.

If I turn off the TrackIR altogether by shutting down the software my FPS go up into the 40's.

If I take off my hat while the TrackIR is on and the game is playing, my FPS will shoot back up into the 40's.

If I unplug the TrackIR from the USB port while everything is running my FPS returns into the 40's.

Any ideas on why this might be? I have uninstalled and reinstalled the software and hardware with no change in the behavior.

Oracle
Posts: 21
Joined: Thu Jan 19, 2006 5:00 am
Location: New Jersey

Re: FPS Loss

Post by Oracle » Wed Feb 01, 2006 6:31 am

I'll also add that if I stay perfectly still, with the TrackIR on, the Frame rate remains low at ~14 FPS.

Toady
Posts: 94
Joined: Sun Jan 08, 2006 5:00 am
Location: Cornwall, UK.

Re: FPS Loss

Post by Toady » Wed Feb 01, 2006 7:07 am

Does it appear to be running at that speed (jerko-vision) or is that just the reported speed of the FPS counter you're using?
Cant say Ive noticed any drop on my system; but then again I normally go by line of eye.
Going to have a play now with a couple of programs and have a look-see.
The Toad Report coming up.

Oracle
Posts: 21
Joined: Thu Jan 19, 2006 5:00 am
Location: New Jersey

Re: FPS Loss

Post by Oracle » Wed Feb 01, 2006 7:14 am

There is a definite sharp drop in FPS that my eyes can see when running with the TIR and there is no drop when running without it.

I am using the Z key to display the frame rate from within CFS3.

Also I just noticed the header on this forum asking for the Serial Number and Software version. I'll post that when I get home tonight.

[ February 01, 2006, 02:14 PM: Message edited by: Oracle ]

Oracle
Posts: 21
Joined: Thu Jan 19, 2006 5:00 am
Location: New Jersey

Re: FPS Loss

Post by Oracle » Wed Feb 01, 2006 10:19 am

Serial 43946
Software Version: 4.1 Build 28

Oracle
Posts: 21
Joined: Thu Jan 19, 2006 5:00 am
Location: New Jersey

Re: FPS Loss

Post by Oracle » Wed Feb 01, 2006 11:46 am

Problem solved!

I pushed the TrackIR as far away from me as possible and the problem is gone.

It was about 24" away before and now it's about 36" away from me. It is working just fine with a much smaller framerate hit.

rodom
Posts: 581
Joined: Thu Jul 07, 2005 5:00 am
Location: Philomath, OR

Re: FPS Loss

Post by rodom » Wed Feb 01, 2006 2:51 pm

Was just going to ask you your distance away.

Good news!

Toady
Posts: 94
Joined: Sun Jan 08, 2006 5:00 am
Location: Cornwall, UK.

Re: FPS Loss

Post by Toady » Wed Feb 01, 2006 5:00 pm

Try not using TIR and use mouse look or the joystick hat instead mate to see if there is a comparison.
In theory TIR uses very little system resource so it might just be you're working the graphics card that much harder by looking around.

Oracle
Posts: 21
Joined: Thu Jan 19, 2006 5:00 am
Location: New Jersey

Re: FPS Loss

Post by Oracle » Wed Feb 01, 2006 5:14 pm

Nope my frame rate stays right up there when using the hatswitch and the view panning mode in CFS3.

I drop to 14 FPS even when running with all the sliders set to 1 and in 800x600x16 graphics.

Toady
Posts: 94
Joined: Sun Jan 08, 2006 5:00 am
Location: Cornwall, UK.

Re: FPS Loss

Post by Toady » Thu Feb 02, 2006 3:17 am

Weired. Whys that then Rick?

Post Reply