Page 1 of 2

New MB -> TrackIR not working?

Posted: Tue Apr 12, 2011 12:57 pm
by mjaspers23
I have something that breaks my head :)

I have bought a new motherboard, processor and memory and after installing it my TrackIR is behaving very strangely.

When I start up the TIR software (either version 4 or 5) it tells me the camera is connected (which only works after switching off the energy management of the USB hub) and I can see the program detects my head movement, but after 2-5 seconds it freezes and it won't work until I restart the software, after which it works again for only 2-5 seconds...

I have tried both version 4 and 5 on windows XP and windows 7. All giving me the same result.

Since this happens on both versions of windows, I have a feeling it is related to the motherboard drivers, but I'm not sure. The new board is an MSI P67A-GD65 B3.

Has anyone encountered a problem like this?

Small update (CET 22:48): I have plugged the camera into my keyboard and now it works... Still not sure why it doesn't work when it is connected directly

Re: New MB -> TrackIR not working?

Posted: Tue Apr 12, 2011 3:32 pm
by NaturalPoint - Mike
Try a reinstallation of your chipset drivers, and ensure that they are the appropriate version for your copy of windows. Improper chipset drivers can effect the power output to the device and cause crashes.

Re: New MB -> TrackIR not working?

Posted: Tue Apr 12, 2011 10:49 pm
by mjaspers23
Thanks for your fast reply!

I will try to do that tonight and see what happens.

Re: New MB -> TrackIR not working?

Posted: Thu Apr 14, 2011 6:36 am
by mjaspers23
I have tried a lot now:
- installed new drivers
- installed new bios
- removed usb root hub and let windows reinstall it
- plugged TIR into the front usb ports
- disabled USB selective suspend setting
No luck so far, it still freezes.

Strange thing is, that the TIR is the only thing reacting like this, all other components, like mouse, keyboard and HOTAS seem to work.

One thing that strikes me is that with software version 4, I see "no data" in the lower left hand corner at the moment it stops working. As if it somehow looses the track clip (although the LEDs on it are still on).

Another thing is that even though the head movement is not detected anymore, the software still works and the TrackIR is still recognized by the software (still showing as device: TrackIR 4).

I'll keep on looking for a solution, but any help is much appreciated.

Re: New MB -> TrackIR not working?

Posted: Fri Apr 15, 2011 1:44 pm
by mjaspers23
Through MSI support I first got new firmware, but that didn't solve it and then they advised me to buy a PCI-E USB card, which I did. And now I can use my TrackIR again!

Still weird that it doesn't work with the motherboard USB ports and that I had to buy an additional card, but I'm happy nevertheless :)

Re: New MB -> TrackIR not working?

Posted: Fri Apr 15, 2011 3:07 pm
by NaturalPoint - Mike
It is possible that the USB ports on the motherboard do not provide enough power to the TrackIR, however that would not explain function through the keyboard unless there was a powered USB hub between the computer and keyboard. Did MSI give any explaination?

Re: New MB -> TrackIR not working?

Posted: Sat Apr 16, 2011 7:51 am
by mjaspers23
I think you are right with the power not being enough since it also did not work through my keyboard. At first I thought it worked, but later it started freezing in the same way again.

MSI did not give me any further explanation, but I will try to get one :)

Re: New MB -> TrackIR not working?

Posted: Tue Apr 19, 2011 3:05 am
by mjaspers23
The answer MSI gave me:
The motherboard follows the intel USB standard.
In case an accessory needs more power a specific adapter is delivered.
Until now there are no known issues with Intel's USB controller.
We think it is a compatability problem.

So I guess it is a compatability problem between Intel's USB controller and my TIR.

I have to say that MSI support is very responsive, they reply very quickly!

Re: New MB -> TrackIR not working?

Posted: Tue Apr 19, 2011 4:28 pm
by NaturalPoint - Mike
I would have to disagree with their diagnosis. The TrackIR 5, even with a TrackClip Pro, does not exceed the maximum power output according to the USB standard (900ma@5v).

One of three things is happening:
1: The TrackIR is overdrawing (Unlikely, as this would more than likely cause the device to burn out).
2: Intel under engineered their USB specifications (Highly unlikely, I've personally used TrackIR cameras on multiple revisions of Intel's USB system without incident)
3: That particular mainboard is not providing the appropriate power to the USB ports (most likely).

To rule out #1, I would try running the TrackIR on a known good computer system through direct connection. If the TrackIR works there, it is likely the motherboard. If it is not, it is likely the Trackir.

Re: New MB -> TrackIR not working?

Posted: Wed Apr 20, 2011 5:20 am
by mjaspers23
I tested it on my laptop and everything worked over there so most likely it is related to the motherboard. The only thing that is very strange, is that it is only happening with the TrackIR and not with any of my other devices.