Trackir4 not working

Vulcan
Posts: 8
Joined: Sun May 03, 2009 1:39 pm

Trackir4 not working

Post by Vulcan » Mon Oct 24, 2011 2:51 am

OS Win7 64bit.

I had the 5.1.3 software installed and TrackIR worked perfectly but I wanted to try v4 of the software to see if it resolved a problem with FSX.
Unplugged the TIR camera and deleted the software via the 5.1.3 installation exe. Rebooted the PC and checked that TIR was not listed in the control panel program file list.

Ran the 4.1.038 installer which ran OK, shortcut on desktop.
Plugged in the TIR camera and got a pop-up that said the device driver was installed.
Double clicked the shortcut but nothing happened.
Checked in Task Manager and trackIR.exe *32 is a process so i assume it is running.
Device manager shows NaturalPoint TrackIR 4 under the USB controllers list.
If I double click the desktop shortcut again the TIR window opens but remains blank. If I click view->tracking and then click settings I get "TrackIR has stopped working"

Can you offer any advice please?

TIA
Dave

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Trackir4 not working

Post by NaturalPoint - Mike » Fri Oct 28, 2011 3:57 pm

Let's try some installation troubleshooting:

Unplug your camera, and uninstall the TrackIR software.
Download a new copy of the latest version of the TrackIR software, and save it to your desktop (note: do not run from the downloader).
Right click on the installer, and select "Run as administrator" (even if your account is an administrator) Finish the installation as normal, plug in your camera, and verify that drivers are properly installed via the device manager.
Run the software, and see if it works properly.

Vulcan
Posts: 8
Joined: Sun May 03, 2009 1:39 pm

Re: Trackir4 not working

Post by Vulcan » Sat Oct 29, 2011 3:01 pm

Ah, well you see Mike that doesn't help because TrackIR works fine with the latest software version as stated in my original post "I had the 5.1.3 software installed and TrackIR worked perfectly...."

What I wanted to do was try the earlier v4 software, it's that software that's not working.

Cheers

Dave

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Trackir4 not working

Post by NaturalPoint - Mike » Mon Oct 31, 2011 12:37 pm

In this case, the latest version would refer to the latest version of 4.x software, 4.1.038. It's located here.

Vulcan
Posts: 8
Joined: Sun May 03, 2009 1:39 pm

Re: Trackir4 not working

Post by Vulcan » Tue Nov 01, 2011 2:04 am

Sorry Mike, I seem to have caused some confusion.

I have software version 5.1.3 running well with my TrackIR 4 Pro hardware.

What I wanted to do was to try running 4.1.038 software, it's that software that isn't working. Symptoms as explained in my OP.

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Trackir4 not working

Post by NaturalPoint - Mike » Tue Nov 01, 2011 8:45 am

Did running the TrackIR 4.1.038 installer as administrator (as described above) cause the problem to go away?

Vulcan
Posts: 8
Joined: Sun May 03, 2009 1:39 pm

Re: Trackir4 not working

Post by Vulcan » Thu Nov 03, 2011 2:11 pm

[quote=NaturalPoint - Mike]Did running the TrackIR 4.1.038 installer as administrator (as described above) cause the problem to go away? [/quote]

No Mike. Symptoms same as before. Double click shortcut, nothing happens but trackir.exe appears in processes in Taskmanager.

Don't worry about it, I'll carry on with software v 5.1.3 which does work.
Thanks for your help.

Dave

warrior2seven
Posts: 3
Joined: Sat Nov 05, 2011 3:06 pm

Re: Trackir4 not working

Post by warrior2seven » Sat Nov 05, 2011 3:28 pm

Ok so my TIR 4:PRO has stopped working.

When I plug in my camera no lights come on. I get a pop up that says "USB Device Not Recognized".

I have followed the troubleshooting tips listed above, but my drivers do not seem to load corectly.

When I open my device manager the TIR is listed under my USB Controllers as "Unknown Device". When I right click on it and open properties it reads under Device Status- "Windows has stopped this device because it has reported problems. (Code 43)".

When I click on Driver Details I get a pop up that says " No driver files are required or have been loaded for this device"

When I try and update the drivers from the device manager and point it to my C:\Program Files (x86)\NaturalPoint\TrackIR4\Drivers I get a pop up thats says "Windows has determined the driver software for your device is up to date"

The only thing I have not tried, and wont be able to until monday, is to plug it into another computer. Is there anything else that I'm not doing correctly or missing?

*EDIT* tried both versions 5.1.3 and 4.1.038.

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Trackir4 not working

Post by NaturalPoint - Mike » Mon Nov 07, 2011 4:00 pm

You can try going to the details tab, then getting the hardware IDs for the device. It should be in a format similar to this:

USB\VID_####%PID_####&REV_####

Post the actual strings here, they should be in hex notation (0-9, A-F)

warrior2seven
Posts: 3
Joined: Sat Nov 05, 2011 3:06 pm

Re: Trackir4 not working

Post by warrior2seven » Mon Nov 07, 2011 6:49 pm

When I select Hardware IDs in the Property drop down menu it says-

USB\UNKNOWN

Post Reply