TrackClip Pro Arm sensor arm broken

ramalls
Posts: 2
Joined: Thu Nov 21, 2013 1:04 pm

TrackClip Pro Arm sensor arm broken

Post by ramalls » Thu Nov 21, 2013 1:29 pm

The swivel sensor arm on my trackclip pro has broken and I'd like to inquire about a replacement or a fix to this broken arm. I've attached photos of the broken device. Your help would be greatly appreciated.

Roosevelt Simmons
20131121_121257-2.jpg
20131121_121257-2.jpg (49.15 KiB) Viewed 7179 times
20131121_121212-2.jpg
20131121_121212-2.jpg (70.27 KiB) Viewed 7179 times

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TrackClip Pro Arm sensor arm broken

Post by MikeWitham » Thu Nov 21, 2013 3:43 pm

Roosevelt,

I would be more than happy to help you. Please submit a ticket at help.naturalpoint.com.

Regards,

Mike Witham
Technical Support
TrackIR | SmartNav
Mike Witham
TrackIR Product Manager

ramalls
Posts: 2
Joined: Thu Nov 21, 2013 1:04 pm

Re: TrackClip Pro Arm sensor arm broken

Post by ramalls » Thu Nov 21, 2013 8:07 pm

Mike,

Thank you for the prompt response. I've submitted the ticket as requested.

Sincerely,

Roosevelt Simmons

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TrackClip Pro Arm sensor arm broken

Post by MikeWitham » Fri Nov 22, 2013 10:18 am

Roosevelt,

Thank you for submitting the ticket. I will take care of it personally.
Mike Witham
TrackIR Product Manager

Stubbies
Posts: 2
Joined: Mon Jan 13, 2014 5:00 pm

Re: TrackClip Pro Arm sensor arm broken

Post by Stubbies » Mon Jan 13, 2014 5:10 pm

Ok just tagging off of this guys post as he has the problem that almost everyone using TIR with the pro clip in our VFS has. I had bought my first one and had it for awhile before that joint broke and bought a replacement. I didn't think much of it as I hadn't been walking on egg shells with the first one so I just paid for my own replacement.

That replacement part joint broke in LESS than a month with me treating it nicely. I just said screw it and used twist ties to hold it in place and that works good enough. I wasn't going to bother posting on it till I saw the subject come up on our VFS forum and the problem is universally the same. The only difference are the fixes implemented.

This isn't for me to get a replacement part because honestly if you guys haven't fixed that problem what would be the point of giving me another one that would break.

The main point being is the joint pictured from the OP is garbage and NEEDS to be re-engineered.

caserock
Posts: 3
Joined: Fri Oct 24, 2008 11:04 pm

Re: TrackClip Pro Arm sensor arm broken

Post by caserock » Sat Feb 08, 2014 6:10 pm

I have mine rigged up with a 1 inch piece I clipped from one of my girlfriend's hair pins, and some duct tape (obviously).

Mine lasted several years and quite a few drops before it gave up. Upon inspection, it looks as if all the part really needs is just a little rib molded into the clip tabs for the arms to give it a little more rigidity, and problem solved!

Maybe for Trackir6!

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TrackClip Pro Arm sensor arm broken

Post by MikeWitham » Tue Feb 11, 2014 11:55 am

Hello CaseRock,

Thank you for the solution!
Mike Witham
TrackIR Product Manager

Kamikaze1111
Posts: 5
Joined: Mon Dec 13, 2004 5:00 am
Location: Lancaster, CA

Re: TrackClip Pro Arm sensor arm broken

Post by Kamikaze1111 » Thu Aug 14, 2014 10:42 am

I am a long time TIR user (from version 3 up to now) and currently have this issue with my Proclip.

From the tail end of this thread . . .had the TrackClip been redesigned yet? So it is more stable? (read as STRONG)

I would be more inclined to purchase another . . .IF . . this has occurred.

Great Product! Its just the weak point at this joint that is frustrating (second one I have had break on me).

onyxius
Posts: 4
Joined: Thu Aug 28, 2014 5:50 pm

Re: TrackClip Pro Arm sensor arm broken

Post by onyxius » Thu Sep 04, 2014 9:28 pm

I just got the TrackIR5 and pro clip ordered for me by my wife and son. I have been reading on some info since I'm new to TrackIR5 and pro clip. I'm really concerned now that part of it was a waste of money and should have just gone with Free track and purchased the led addon from someone in their community and still save a bunch of money.

I don't see a reply on if this is actually fixed / re-designed. I imagine over all of these years the issue is still happening, they dont much care. I am seeing threads back to 2009, soooo 5 years now with the same issue, would hope its fixed.

Thanks

Seth Steiling
Posts: 1366
Joined: Fri Jun 27, 2008 11:29 am
Location: Corvallis, Oregon

Re: TrackClip Pro Arm sensor arm broken

Post by Seth Steiling » Thu Oct 02, 2014 1:36 pm

Hi Kamikaze1111 and onyxius,

So sorry for the very delayed response, guys. I don't know how this slipped through the cracks, but it did.

In short, we have indeed made significant changes to both the materials and underlying structure of the TrackClip PRO—including reinforcements to the joint mentioned in this thread. As a result, the failure rate in the field has gone way down. Part of what seemed like a delay in how we responded to this issue was just us searching for what turned out to be a brutally inconspicuous problem with our original plastics, where they would only fail after being exposed to conditions that only appear during long-duration air shipping. We couldn't easily reproduce those conditions in-house, so it took a while to determine what was wrong, and how to fix it. The new plastics are far more durable when exposed to these extreme conditions, and we've reinforced the plastics underneath to make the unit extra resilient.
Marketing Manager
TrackIR | OptiTrack

Post Reply