TCP broke at joint... suggestions?

Post Reply
ryanbatc
Posts: 20
Joined: Wed Feb 17, 2010 10:55 am

TCP broke at joint... suggestions?

Post by ryanbatc » Tue Dec 09, 2014 1:05 pm

My TCP broke at this point... the little "grabber" feet snapped off (one side did) - anyone have an idea on how to mend this connection but keep the swivel function intact?

Image

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TCP broke at joint... suggestions?

Post by MikeWitham » Wed Dec 10, 2014 1:12 pm

Hello ryanbatc,

I'm sorry to see that it has broken at the joint. I don't know of any way to repair it and keep the swivel function. Would you please create a ticket with me at help.naturalpoint.com so I can see if there is anything I can do to help you out?

Regards,
Mike Witham
TrackIR Product Manager

Jwhal
Posts: 2
Joined: Sun Jan 11, 2015 8:35 am

Re: TCP broke at joint... suggestions?

Post by Jwhal » Sun Jan 11, 2015 8:54 am

my fix.JPG
my fix.JPG (91.36 KiB) Viewed 3168 times
Mine broke in a couple places this is what I used to mend it but you loose movement in the joints.

Jwhal
Posts: 2
Joined: Sun Jan 11, 2015 8:35 am

Re: TCP broke at joint... suggestions?

Post by Jwhal » Sun Jan 11, 2015 8:58 am

This is how I fixed mine broke in two places.
You loose the movement of the joints.
my fix.JPG
My fix
my fix.JPG (91.36 KiB) Viewed 3168 times

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TCP broke at joint... suggestions?

Post by MikeWitham » Mon Jan 12, 2015 5:22 pm

Jwhal,

Thank you for posting your solution. QuikSteel is a pretty solid solution!

Regards,
Mike Witham
TrackIR Product Manager

ryanbatc
Posts: 20
Joined: Wed Feb 17, 2010 10:55 am

Re: TCP broke at joint... suggestions?

Post by ryanbatc » Tue Jan 20, 2015 8:43 pm

Sorry for now following up

I just used some painter's tape to hold it in place. That epoxy looks to be a more permanent :twisted: idea hehe

Post Reply