TCP causing USB over current error

Post Reply
Posts: 2
Joined: Sun Jan 17, 2016 2:32 pm

TCP causing USB over current error

Post by Pallywoods » Mon Sep 05, 2016 12:32 am

So earlier this evening I was playing ArmA III and right as I logged off, I lost all sound to my headset. Weird? I then turned on my speakers while I was eating to then have yet another USB device disconnect on me and unable to reconnect itself. This told me to shut down the computer before anything else blew.

So I clicked restart left to go get a drink and find the computer is not even powered on. Again, weird. I turn it on via the power button, it POSTs, gets to BIOS, and then a splash screen that tells me all of my computer's specs and at the very bottom it states, "USB Device Over Current Status Detected!! System will shut down after 15 seconds". Kept getting this for awhile while I was trying to see which USB "device" was the issue. At the time I was assuming a port blew and oh well, I suppose that happens after sometime.

Well I consulted a programmer friend of mine who told me to just unplug everything but the keyboard and mouse and get into the bios and check the ports. Computer actually started up and the keyboard was functioning this time allowing me to get into the BIOS and verify that all 12 USB ports are functioning. I then plugged in the TrackIR 5 via track clip pro connection (in a different port it was in before) and got the splash screen again and the keyboard (Razer 2012 Blackwidow Ultimate) did not function yet again. Interesting.

I then plugged everything in except for the trackIR and it started just fine. Everything worked etc.
Now the kicker is while everything is turned on, I plug in just the trackIR w/out the track clip expecting the worst. But it actually worked just fine. Pull it out and plug it into the clip pro, clip pro into a usb slot, and instantly TrackIR camera fails + keyboard fails. I am rewarded with a notification of a power outage in a USB slot by windows 7.

So I even made a quick two minute video on my phone showing this off. It is certainly the clip pro causing the issues. Other things I have tried are reinstalling the motherboard drivers. I understand too that one other solution would be to reinstall windows 7 itself but that is a large hassle for me atm.

I'm really just curious if this is even solvable and if it isn't, what my options are.
Error Message:
Working Ports:

NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TCP causing USB over current error

Post by MikeWitham » Thu Sep 08, 2016 3:29 pm


I am looking into this, but I did have one question before I really start digging in. Does the issue show up if you plug them both in, but to separate ports?

Mike Witham
TrackIR Product Manager

Post Reply