Problem with TT_Update() [Tracking Tools API]

Post Reply
davidr
Posts: 2
Joined: Tue Jan 07, 2014 5:43 pm

Problem with TT_Update() [Tracking Tools API]

Post by davidr » Tue Jan 07, 2014 5:53 pm

Hi there,

I'm getting started with 8 Flex13 cameras and Tracking Tools. I'm hoping to write my own code using the Tracking Tools API and as a starting point I'm attempting to build and run the 'markers' sample code.

The issue I'm having is that calling TT_Update() throws the following exception:
First-chance exception at 0x101fc5aa in markers.exe: 0xC0000005: Access violation reading location 0x00027914.
Unhandled exception at 0x101fc5aa in markers.exe: 0xC0000005: Access violation reading location 0x00027914.
Sometimes restarting my PC seems to resolve the problem, however, subsequent attempts to run the code without restarting encounter the same problem.

I've also noticed that numbers do not appear on the cameras following initialisation - so am wondering if this is part of the problem..

If anyone is able to help me resolve this issue I'd be very appreciative!

:)

davidr
Posts: 2
Joined: Tue Jan 07, 2014 5:43 pm

Re: Problem with TT_Update() [Tracking Tools API]

Post by davidr » Tue Jan 07, 2014 11:00 pm

I seem to have resolved the issue by applying the following edit as suggested in this thread http://forums.naturalpoint.com/viewtopi ... =56&t=9027

Code: Select all

    TT_Initialize();

    while(TT_CameraCount()==0)
    {
        TT_Update();
        Sleep(5);
    }

    TT_LoadProject(...);

NaturalPoint-Dustin
Posts: 612
Joined: Tue Mar 19, 2013 5:03 pm

Re: Problem with TT_Update() [Tracking Tools API]

Post by NaturalPoint-Dustin » Wed Jan 08, 2014 3:34 pm

Hi David,

Thank you for the status update. Please let us know if you have further questions.
Dustin
Technical Support Engineer
OptiTrack | TrackIR | SmartNav

Post Reply