natnetlib.dll

Post Reply
michaweyel
Posts: 5
Joined: Tue Mar 11, 2008 8:59 am

natnetlib.dll

Post by michaweyel » Tue Mar 11, 2008 9:02 am

Hi all,

I am writing an application to read rigid body data from the rigid body toolkit stream using NatNetLib. I can't start my app, though, because it complains about not finding NatNetLib.dll, same thing happens why I try to run the SampleClient.

Where can I find this DLL, or is it something else that I'm doing wrong?

Thanks,
-michael

beckdo
NaturalPoint Employee
NaturalPoint Employee
Posts: 519
Joined: Tue Jan 02, 2007 2:02 pm

Re: natnetlib.dll

Post by beckdo » Tue Mar 11, 2008 11:56 am

The easiest way is to get it from the stream sample code for the NaturalPoint (NatNet) Streaming Sample Distribution Files.

http://www.naturalpoint.com/optitrack/s ... #streaming

michaweyel
Posts: 5
Joined: Tue Mar 11, 2008 8:59 am

Re: natnetlib.dll

Post by michaweyel » Wed Mar 12, 2008 5:50 am

Hi Doug,

do you mean the NaturalPoint Streaming 1.30.zip? That is exactly the file I downloaded, it contains the natnetlib.lib and all the headers, but not the .dll

beckdo
NaturalPoint Employee
NaturalPoint Employee
Posts: 519
Joined: Tue Jan 02, 2007 2:02 pm

Re: natnetlib.dll

Post by beckdo » Wed Mar 12, 2008 11:54 am

Sure enough, it's missing. We'll get an updated download up there by this time tomorrow.

michaweyel
Posts: 5
Joined: Tue Mar 11, 2008 8:59 am

Re: natnetlib.dll

Post by michaweyel » Thu Mar 13, 2008 1:29 am

Thanks :)

michaweyel
Posts: 5
Joined: Tue Mar 11, 2008 8:59 am

Re: natnetlib.dll

Post by michaweyel » Thu Mar 13, 2008 4:07 am

Hi Doug,

I downloaded the new version and the dll was there. However, now I can link neither my program nor the sample client, I get a lot of unresolved symbols, even though I am sure that I have the NatNetLib.lib included in my Additional Libraries in the linker settings. Could it be some kind of version conflict?

Here are the errors I get:

SampleClient.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: int __thiscall NatNetClient::Uninitialize(void)" (__imp_?Uninitialize@NatNetClient@@QAEHXZ) referenced in function _main
1>SampleClient.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: int __thiscall NatNetClient::GetDataDescriptions(struct sDataDescriptions * *)" (__imp_?GetDataDescriptions@NatNetClient@@QAEHPAPAUsDataDescriptions@@@Z) referenced in function _main
1>SampleClient.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: int __thiscall NatNetClient::GetServerDescription(struct sServerDescription *)" (__imp_?GetServerDescription@NatNetClient@@QAEHPAUsServerDescription@@@Z) referenced in function _main
1>SampleClient.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: int __thiscall NatNetClient::SetDataCallback(void (__cdecl*)(struct sFrameOfMocapData *))" (__imp_?SetDataCallback@NatNetClient@@QAEHP6AXPAUsFrameOfMocapData@@@Z@Z) referenced in function _main
1>SampleClient.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: void __thiscall NatNetClient::SetVerbosityLevel(int)" (__imp_?SetVerbosityLevel@NatNetClient@@QAEXH@Z) referenced in function _main
1>SampleClient.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: int __thiscall NatNetClient::SetMessageCallback(void (__cdecl*)(int,char *))" (__imp_?SetMessageCallback@NatNetClient@@QAEHP6AXHPAD@Z@Z) referenced in function _main
1>SampleClient.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: void __thiscall NatNetClient::NatNetVersion(unsigned char * const)" (__imp_?NatNetVersion@NatNetClient@@QAEXQAE@Z) referenced in function _main

-Michael

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: natnetlib.dll

Post by VincentG » Thu Mar 13, 2008 10:24 am

Are you running it against the Rigid Body toolkit, or the Arena software?

beckdo
NaturalPoint Employee
NaturalPoint Employee
Posts: 519
Joined: Tue Jan 02, 2007 2:02 pm

Re: natnetlib.dll

Post by beckdo » Thu Mar 13, 2008 11:15 am

Hi Micheal,

You are correct. The sample code needed to be updated to match the Lib/DLL. I apologize for the delay on this. I just submitted a reworked & tested of the sample app to be posted to the site. I tested the sample app against the latest version of the Rigid Body Tool.

michaweyel
Posts: 5
Joined: Tue Mar 11, 2008 8:59 am

Re: natnetlib.dll

Post by michaweyel » Fri Mar 14, 2008 2:58 am

ok, thanks again. And to Vincent, I am running the Rigid Body Toolkit

Post Reply