Page 1 of 1

TT_Initialize returns "Invalid License"

Posted: Sun Jul 18, 2010 10:37 am
by iko79

I have some problems getting my application to work on a demonstration PC. TT worked fine on my development platform, however, I am not able to initialize the API. I built the application on my development PC, linked it against the lib of the same version I am using on the demo PC, I use the same dlls. To set up TT on the demo PC I use the same installer, to activate the software I use the same license serial, license hash, hardware key, e-mail address and name, I use the same hardware on the demo PC I used on the development PC before, both PCs run the same operating system (Win7 32bit). The activation succeeds, also TrackingTools runs fine (!) BUT if I run my application and it calls TT_Initialize() it quits saying "Invalid License".

Please help, urgent!


Re: TT_Initialize returns "Invalid License"

Posted: Tue Jul 20, 2010 9:55 am
by beckdo
Hey iko,

I've requested support contact you directly so we can get this resolved quickly.


Re: TT_Initialize returns "Invalid License"

Posted: Tue Jul 20, 2010 2:11 pm
by iko79
Hi Doug,

thanks again for your reply, as mentioned in my mail I post this here in more detail:

I shortly figured out per accident what the problem was, although I still do not understand how this happened. I installed TrackingTools using the installer on the demo-PC to C:\program files\ and also ran the activation tool from this folder. However the license file produced by the tool ended up not in the optitrack folder where it should but in the demo-folder where I have a copy of the library for building purposes (I copied all sources, libraries and code to that folder from my development-PC as I tried out building the project on the target platform -- this was one of the things I tried out when I was on my wits' end, longer story, nevermind...). As I copied the license file into the optitrack folder everything finally worked. Really weird story, something obviously went terrible wrong while I tried around with differend setups and versions, still strange why TrackingTools worked all the time and why I had the problem in the first place, before I started messing around.

Long story short: If anyone experiences similar problems and reads this: Doublecheck the location of your license file.

Re: TT_Initialize returns "Invalid License"

Posted: Wed Sep 29, 2010 10:24 am
by dashesy
I also faced exactly same problem, TT software was working fine while TT_initialize was not.
The problem was that Windows7 (and maybe Vista) does not allow the installer to copy the license file to "Program Files (x86)" location but rather copies it to "c:\Users\Username\VirtualStore\Program Files (x86)" location !!!
I copied it to the right folder and now it works fine.