Tracking Tools streaming via natNet client CRASH

Post Reply
ipem
Posts: 9
Joined: Tue Aug 12, 2008 5:26 am

Tracking Tools streaming via natNet client CRASH

Post by ipem » Fri Oct 08, 2010 1:49 am

Hi,

We need some help figuring out a problem. Since the ARENA 1.4 we've been using a sample client based on the natnet to stream our data. The client we've made still works under ARENA 1.6.3 with natNet SDK 2.2. Although we consistently can recreate an error:

When starting the streaming (in Arena) before the client it causes the client to crash. When starting the client first and the streaming next everything works fine!

We want to use the tracking tools instead of the arena software now. The starting-order-crash we had in Arena seems to persist here as well. We suppose it's because when you start "Broadcast Frame Data" it instantiates the server and immediately starts streaming, thus crashing the client. There is however not an option (like in arena) to start the server and than press play to start the streaming.

We're puzzled by this behavior and have no clue what is wrong here, any thoughts someone?

PS The executable of the sample client in the natNet 2.2 seems to work fine, but we can not open the visual studio project in order to recompile the code, so there is no way of digging in deeper for us

best

pieter

morgan
NaturalPoint Employee
NaturalPoint Employee
Posts: 199
Joined: Tue Jun 24, 2008 2:01 pm
Location: Corvallis, OR, USA
Contact:

Re: Tracking Tools streaming via natNet client CRASH

Post by morgan » Fri Oct 08, 2010 9:50 am

Hey Pieter,

To help us isolate better, can you tell us:

- Is the crash ocurring in TrackingTools / Arena or in your NatNet client program?

- Why are you unable to open the NatNet 2.2 sample project?

- Have you tried rebuilding your sample client program with NatNet 2.2?

thanks

Morgan

Post Reply