Crashing with UE4 4.19.2 and Optitrack Plugin

NatNet, VRPN, TrackD, and Plugins
Post Reply
EnvisionC
Posts: 1
Joined: Fri Nov 02, 2018 8:55 am

Crashing with UE4 4.19.2 and Optitrack Plugin

Post by EnvisionC » Fri Nov 02, 2018 9:07 am

Using the latest beta of motive, the latest optitrack plugin, and UE4 version 4.19.2; the editor crashes upon Play. I've followed both the documentation and the video guide precisely and still have some kind of error that crashes the engine.

Pasting the logs below, which really don't explain much. The plugin successfully connects to the host but doesn't describe anything happening after that (which is when the editor closes and the Epic Games report crash dialog opens).

The setup we are using is the motive machine is streaming the data locally over a router to another machine. The client machine doesn't have actual internet connection because it is connecting to the linking router. I'm not sure if this type of setup would have an impact on the plugin but it works just in Unity with the current plugin.

Any/all help would be greatly appreciated!

Code: Select all

[2018.11.02-15.50.49:944][111]LogTemp: Repeating last play command: Selected Viewport
[2018.11.02-15.50.49:977][111]LogBlueprintUserMessages: Early PlayInEditor Detection: Level '/Game/StarterContent/Maps/Minimal_Default.Minimal_Default:PersistentLevel' has LevelScriptBlueprint '/Game/StarterContent/Maps/Minimal_Default.Minimal_Default:PersistentLevel.Minimal_Default' with GeneratedClass '/Game/StarterContent/Maps/Minimal_Default.Minimal_Default_C' with ClassGeneratedBy '/Game/StarterContent/Maps/Minimal_Default.Minimal_Default:PersistentLevel.Minimal_Default'
[2018.11.02-15.50.49:977][111]LogPlayLevel: PlayLevel: No blueprints needed recompiling
[2018.11.02-15.50.49:978][111]PIE: New page: PIE session: Minimal_Default (Nov 2, 2018, 7:50:49 AM)
[2018.11.02-15.50.49:978][111]LogPlayLevel: Creating play world package: /Game/StarterContent/Maps/UEDPIE_0_Minimal_Default
[2018.11.02-15.50.49:983][111]LogPlayLevel: PIE: StaticDuplicateObject took: (0.005411s)
[2018.11.02-15.50.49:984][111]LogAIModule: Creating AISystem for world Minimal_Default
[2018.11.02-15.50.49:985][111]LogPlayLevel: PIE: World Init took: (0.001236s)
[2018.11.02-15.50.49:985][111]LogPlayLevel: PIE: Created PIE world by copying editor world from /Game/StarterContent/Maps/Minimal_Default.Minimal_Default to /Game/StarterContent/Maps/UEDPIE_0_Minimal_Default.Minimal_Default (0.006878s)
[2018.11.02-15.50.50:010][111]LogInit: XAudio2 using 'Digital Audio (S/PDIF) (High Definition Audio Device)' : 2 channels at 44.1 kHz using 16 bits per sample (channel mask 0x3)
[2018.11.02-15.50.50:022][111]LogInit: FAudioDevice initialized.
[2018.11.02-15.50.50:063][111]LogLoad: Game class is 'GameModeBase'
[2018.11.02-15.50.50:070][111]LogWorld: Bringing World /Game/StarterContent/Maps/UEDPIE_0_Minimal_Default.Minimal_Default up for play (max tick rate 0) at 2018.11.02-11.50.50
[2018.11.02-15.50.50:071][111]LogWorld: Bringing up level for play took: 0.005900
[2018.11.02-15.50.50:076][111]LogContentBrowser: Native class hierarchy updated for 'MovieSceneCapture' in 0.0005 seconds. Added 11 classes and 0 folders.
[2018.11.02-15.50.50:078][111]LogOptitrack: [NatNet - Info]: NatNetClient::Connect: Switching client to unicast based on sNatNetClientConnectParams::connectionType.
[2018.11.02-15.50.50:078][111]LogOptitrack: [NatNet - Info]: [Client] Initializing using my address: 192.168.1.126
[2018.11.02-15.50.50:079][111]LogOptitrack: [NatNet - Info]: [Client] Initializing command listener.
[2018.11.02-15.50.50:099][111]LogOptitrack: [NatNet - Info]: [Client] Host information received. (HostApp: Motive  HostVer: 2.1.0.0  HostIP: 192.168.1.125 ()
[2018.11.02-15.50.50:099][111]LogOptitrack: [NatNet - Info]: [Client] Connected.
[2018.11.02-15.50.50:111][111]LogOptitrack: [NatNet - Debug]: [Client] Requesting: GetProperty,,Bone Naming Convention
[2018.11.02-15.50.50:112][111]LogOptitrack: [NatNet - Debug]: [Client] Requesting: SetProperty,,Skeleton Coordinates,true
[2018.11.02-15.50.50:114][111]PIE: Play in editor start time for /Game/StarterContent/Maps/UEDPIE_0_Minimal_Default -0.65
[2018.11.02-15.50.50:114][111]LogBlueprintUserMessages: Late PlayInEditor Detection: Level '/Game/StarterContent/Maps/Minimal_Default.Minimal_Default:PersistentLevel' has LevelScriptBlueprint '/Game/StarterContent/Maps/Minimal_Default.Minimal_Default:PersistentLevel.Minimal_Default' with GeneratedClass '/Game/StarterContent/Maps/Minimal_Default.Minimal_Default_C' with ClassGeneratedBy '/Game/StarterContent/Maps/Minimal_Default.Minimal_Default:PersistentLevel.Minimal_Default'
[2018.11.02-15.50.50:117][111]LogWindows: Windows GetLastError: The operation completed successfully. (0)

Post Reply