Problem receiving data in MATLAB R2013a

NatNet, VRPN, TrackD, and Plugins
Post Reply
notjonmadden
Posts: 1
Joined: Fri Mar 07, 2014 2:04 pm

Problem receiving data in MATLAB R2013a

Post by notjonmadden » Mon Jun 02, 2014 10:03 am

I am trying to run the NatNetMatlabSample.m program. I already set the path for the NatNetML.dll

Code: Select all

 % TODO : update the path to your NatNetML.DLL file here
dllPath = fullfile('c:','NatNetSDK2.6','lib','x64','NatNetML.dll');%updated
Motive:tracker is already up and running with two rigid bodies just sitting in the middle of my arena.

When I run NatNetMatlabSample.m, I get:
NatNet Sample Begin
[NatNet] Creating Client.
[NatNet] Client Version : 2.6.0.0
[NatNet] Connecting to OptiTrack Server.
[NatNet] Initialization Succeeded
[NatNet] Tracking Models : 0

[NatNet] FrameReady Listener added.

and an empty data window.

I'm probably missing something trivial, but I am not very familiar with MatLab so it's to be expected. Any help is greatly appreciated.

NaturalPoint-Dustin
Posts: 609
Joined: Tue Mar 19, 2013 5:03 pm

Re: Problem receiving data in MATLAB R2013a

Post by NaturalPoint-Dustin » Fri Jun 06, 2014 4:45 pm

Hello,

Thank you for posting on the forums. I will have a member of our dev team submit a reply as soon as possible.
Dustin
Technical Support Engineer
OptiTrack | TrackIR | SmartNav

NaturalPoint-Dustin
Posts: 609
Joined: Tue Mar 19, 2013 5:03 pm

Re: Problem receiving data in MATLAB R2013a

Post by NaturalPoint-Dustin » Fri Jun 06, 2014 4:52 pm

Hello,

It appears you have this setup correctly. It would be helpful if you could confirm that the rigid body definition is created and tracking. Please try just one rigid body.

Regards,
Dustin
Technical Support Engineer
OptiTrack | TrackIR | SmartNav

orhirshfeld
Posts: 16
Joined: Tue Jun 17, 2014 9:42 am

Re: Problem receiving data in MATLAB R2013a

Post by orhirshfeld » Tue Jun 17, 2014 9:57 am

I'm having the same problem with
Matlab 2013b 64bit
Tracking tools 2.5.3 64bit
Windows 7 64bit
NatNet SDK 2.6

I also tried m file example from Matlab file exchange community (Matlab Central)
file name: TT_Tools_demo by Glen Lichtwark
link: https://forums.naturalpoint.com/posting ... 59&t=12748
https://forums.naturalpoint.com/posting ... 59&t=12748

it's built especially for tracking tools
but the developer admit it's doesn't work in 64bit because of loadlibary of h file issue
i had the same exeprinace

my first goal is only to extract current postion of my object
if possible it would be nice to recored speed and orientation

orhirshfeld
Posts: 16
Joined: Tue Jun 17, 2014 9:42 am

Re: Problem receiving data in MATLAB R2013a

Post by orhirshfeld » Thu Jun 19, 2014 10:10 am

I found that in downloads page of tracking tools there is also NatNet download link but with an older version, NatNet sdk 2.2.

Is it supposed to be more compatible with tracking tools?

also i didn't come a cross Matlab example in the files as opposed to the sample available in NatNet SDK 2.6.
Does it mean it's not compatible with Matlab?

another issue
I saw that with the same licences for Tracking tools you can also activate Motive
But the problem is that Tracking Tools is used by other in the Lab and they wrote C++ code for handling it so i cannot delete it.
Can I also work with both software in parallel? is there any Licences issue and software conflicts doing so?

NaturalPoint-Dustin
Posts: 609
Joined: Tue Mar 19, 2013 5:03 pm

Re: Problem receiving data in MATLAB R2013a

Post by NaturalPoint-Dustin » Thu Jun 19, 2014 11:28 am

Hello,

The MatLab sample is only compatible with Motive 1.5 or greater.
Can I also work with both software in parallel? is there any Licences issue and software conflicts doing so?
There would be a software conflict. You cannot run the software in parallel.
Dustin
Technical Support Engineer
OptiTrack | TrackIR | SmartNav

orhirshfeld
Posts: 16
Joined: Tue Jun 17, 2014 9:42 am

Re: Problem receiving data in MATLAB R2013a

Post by orhirshfeld » Thu Jun 19, 2014 11:55 am

Thank you for your information

so two more question follow and i would be glad if you can assist me

does the the interface is backward compatible
I mean a code written to interface tracking tools would work well with Motive?
as i stated before the guys in the lab programmed C++ interface and I can't tell them to rewrite their programs.

Another issue
Can i install Motive on another computer and use the same licences as the one already installed with Tracking Tools?
also an option they never work toghther on the same time can work for me.
i mean that before I open Motive in my computer I would close Tracking Tools on Lab computer.

thank you
Or Hirshfeld

orhirshfeld
Posts: 16
Joined: Tue Jun 17, 2014 9:42 am

Re: Problem receiving data in MATLAB R2013a

Post by orhirshfeld » Thu Jun 19, 2014 12:09 pm

Ok I got full answer from help desk support personal
No problem to install both software on the same computer with the same licence
But they can't work in parallel only spertally.
also you need to make sure you have active licence in order to install Motive.

thank you all for your help and fast respones

orhirshfeld
Posts: 16
Joined: Tue Jun 17, 2014 9:42 am

Re: Problem receiving data in MATLAB R2013a

Post by orhirshfeld » Sun Apr 26, 2015 2:46 pm


Post Reply