Discussion and Support for the OptiTrack, SmartNav and TrackIR brands by NaturalPoint

Receive no data on Local machine

NatNet, VRPN, TrackD, and Plugins

by Yan Zhang » Thu Jul 06, 2017 6:00 pm

Hi folks,

We use a Motive on Windows and run sample codes from NatNet SDK to test the system. We think the sample codes successfully connect to the Motive server but fail to receive any data.

Below is what we set in the streaming panel in Motive:

Broadcast frame data - check
Local Interface - loopback
Stream Markers - true
Stream Rigid Bodies - true

Advanced setting:
Type - Multicast
Command/Data port: default
Multicast Interface: (IP address that is NOT the local machine address, but in the same LAN as local machine)

VRPN Streaming Engine:
Broadcast Frame Data - check (although we don't need this when using NatNet)

Below are some test results we get:

1. Test VRPN on a remote machine: we can receive pose data via VRPN from another machine (in the same LAN), the code is run on ROS, Ubuntu. Of course at this time, we set the Local Interface to the Motive machine's IP address.

2. Test SimpleClient3D.exe on the local machine: We run SimpleClient3D.exe and use the default server and client IP address ( It can connect to the Motive. We saw the "NET" mark on the right bottom of Motive GUI becomes green. However, the tracked rigid body in Motive GUI is not present in the pop-out window.

3. Test MatlabNatNetSample.m on the local machine: we run this script in Matlab R2014a. The command window shows the list of defined rigid bodies' names and markers. However, no data is shown in the pop-out figure window. It can connect to Motive because of the same reason in 2.

We did some research in the forum. People mentioned it could be the firewall setting. We turn off the firewall on the Motive machine but it doesn't work. We also tried to change Multicast to Unicast. Nothing happens.

We cannot think of anything that could be wrong. Any help or suggestions will be greatly appreciated.

Yan Zhang
Posts: 19
Joined: Fri May 15, 2015 8:26 am

by Yan Zhang » Wed Jul 12, 2017 12:23 pm

Hi folks,

I found one solution to the problem.

I set the "type" under advanced network options to "unicast" and accordingly set matlab code or winform app to receive data in unicast mode and it works.

Somehow we tried this before and it didn't work. I guess we forgot to set either the server side or the client side. Now it works fine.

Out of curiosity, how to make it work in the "multicast" mode? Do I need to do some setting in the client side to make it stop ignoring the multicast data? I guess working in unicast mode means I cannot let multiple robots receive data from the Optitrack at the same time, am I right?

I appreciate any answers!

Yan Zhang
Posts: 19
Joined: Fri May 15, 2015 8:26 am

by bsteagal » Wed Jul 12, 2017 1:42 pm

Hi Yan

Some networks don't allow the use of multicast, or do not support it, all depends on the hardware you have. Being that you are on a school network (if I remember correctly), most will disable this function, you might want to check with your network admin to see if it is disabled or not.
Bryan Steagall
Kidz Korner Studio
OptiTrack Distributor
Mexico, Central and South America
Posts: 306
Joined: Tue Jun 28, 2005 5:00 am
Location: Albuquerque, New Mexico

by Yan Zhang » Wed Jul 12, 2017 8:00 pm

Thanks for the reply, Bryan!

Yes, I am using the internet on campus. However, I am not sure whether this is the internet administration problem. When I set it to multicast and use remote desktop to receive Optitrack data, it works. The remote desktop is in the same LAN as the Motive server machine.

Yan Zhang
Posts: 19
Joined: Fri May 15, 2015 8:26 am

Return to OptiTrack Data Streaming