live data streaming from motive to matlab

NatNet, VRPN, TrackD, and Plugins
Post Reply
sivabala@uw.edu
Posts: 1
Joined: Wed Jul 12, 2017 4:19 pm

live data streaming from motive to matlab

Post by sivabala@uw.edu » Fri Jul 14, 2017 12:46 pm

I have calibrated the cameras and enabled data streaming as per the instructions in the natnet manuals. I want to stream rigid body data from motive to matlab. I had used the natnetmatlabsample.m code. I am running it in live mode. but I don't get any plots. the plotting window just pops up and is empty. The following message appears when i run the code.

NatNetMatlabSample
NatNet Sample Begin
[NatNet] Creating Client.
[NatNet] Client Version : 2.10.0.0
[NatNet] Connecting to OptiTrack Server.
[NatNet] Initialization Succeeded
[NatNet] Tracking Models : 1

MarkerSet : all

Markerset : all (0 markers)
[NatNet] FrameReady Listener added.

steven.andrews
NaturalPoint Employee
NaturalPoint Employee
Posts: 462
Joined: Mon Jan 19, 2015 11:52 am

Re: live data streaming from motive to matlab

Post by steven.andrews » Mon Jul 17, 2017 1:06 pm

Hello sivabala@uw.edu,

It sounds like your client is able to successfully connect to Motive, but does not receive any data afterward. This is most often caused by interference from an antivirus or a firewall.
If you have any firewalls running, including the Windows Firewall, they will most likely need to be disabled before you see data stream correctly. This will have to be done for both the Motive machine and the client machine.

If you continue to struggle with this, please feel free to email us directly for support.

Best,
Steven
--
Steven Andrews
OptiTrack | Senior Customer Support Engineer
help.naturalpoint.com
support@optitrack.com

Post Reply