SampleClient/NatNet across VPN/subnet

NatNet, VRPN, TrackD, and Plugins
Post Reply
Posts: 1
Joined: Tue May 05, 2020 7:36 am

SampleClient/NatNet across VPN/subnet

Post by NatNetUser1 » Tue May 05, 2020 7:44 am

Due to the recent events we have a need for some developers to work with the NatNetSDK from home. We have a very functional VPN that has one subnet and our office has another. We have worked and all the traffic is passing over the firewall/VPN.

I'm seeing :

Code: Select all

NatNet Sample Client (NatNet ver.

[NatNetLib]  [INFO]: [Client] Initializing using ethernet address:

[NatNetLib]  [INFO]: [Client] Initializing command listener.

[NatNetLib]  [INFO]: [Client] Host information received. (HostApp: Motive  HostVer:  HostIP: ()

[NatNetLib] [ERROR]: [Client] Timed out while connecting to server.
Unable to connect to server.  Error code: 3. ExitingError initializing client.  See log for details.  Exiting
(IPs changed for privacy, both subnets are RFC1918 class C).

When I look at everything in Wireshark I see the streaming data being sent from Motive (source port 1511) coming to the operating system and being sent continually, but SampleClient/NatNet does not think it is getting it.

Both devices are Windows 10. Both devices have the Windows firewall disabled.
I am seeing send an ICMP Destination Port Unreachable packet, but I don't know why.

Does anyone have any ideas?

Posts: 4
Joined: Wed Jul 08, 2020 7:48 am

Re: SampleClient/NatNet across VPN/subnet

Post by ThomasC » Tue Jul 21, 2020 2:45 am

Hello, I am battling the same error report. Did you manage to find the issue?

Post Reply