Unable to load NatNet.ML (side by side configuration)

NatNet, VRPN, TrackD, and Plugins
Post Reply
elpiar
Posts: 4
Joined: Thu Mar 04, 2010 8:24 am

Unable to load NatNet.ML (side by side configuration)

Post by elpiar » Thu Apr 15, 2010 8:30 am

I got this error while loading NatnetML.dll in visual studio.

Can anyone help?

I have no problem when I'm running on my windows vista ultimate 64-bit.

Now I'm running on a freshly installed windows vista 32-bit (home basic) with VC runtime and .net installed and got this error.

===

System.InvalidOperationException was unhandled
Message="An error occurred creating the form. See Exception.InnerException for details. The error is: Could not load file or assembly 'NatNetML, Version=2.1.3615.30264, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail. (Exception from HRESULT: 0x800736B1)"
Source="ToolTrackingVB"
StackTrace:
at ToolTrackingVB.My.MyProject.MyForms.Create__Instance__[T](T Instance) in 17d14f5c-a337-4978-8281-53493378c1071.vb:line 190
at ToolTrackingVB.My.MyProject.MyForms.get_Form1()
at ToolTrackingVB.My.MyApplication.OnCreateMainForm() in C:\Users\Administrator\Documents\Visual Studio 2008\Projects\ToolTrackingVB\WinFormsSampleVB\My Project\Application.Designer.vb:line 35
at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun()
at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()
at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(String[] commandLine)
at ToolTrackingVB.My.MyApplication.Main(String[] Args) in 17d14f5c-a337-4978-8281-53493378c1071.vb:line 81
at System.AppDomain._nExecuteAssembly(Assembly assembly, String[] args)
at System.AppDomain.nExecuteAssembly(Assembly assembly, String[] args)
at System.Runtime.Hosting.ManifestRunner.Run(Boolean checkAptModel)
at System.Runtime.Hosting.ManifestRunner.ExecuteAsAssembly()
at System.Runtime.Hosting.ApplicationActivator.CreateInstance(ActivationContext activationContext, String[] activationCustomData)
at System.Runtime.Hosting.ApplicationActivator.CreateInstance(ActivationContext activationContext)
at System.Activator.CreateInstance(ActivationContext activationContext)
at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssemblyDebugInZone()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()
InnerException: System.IO.FileLoadException
Message="Could not load file or assembly 'NatNetML, Version=2.1.3615.30264, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail. (Exception from HRESULT: 0x800736B1)"
Source="ToolTrackingVB"
FileName="NatNetML, Version=2.1.3615.30264, Culture=neutral, PublicKeyToken=null"
FusionLog=""
StackTrace:
at ToolTrackingVB.Form1..ctor()
InnerException: System.Runtime.InteropServices.COMException
Message="The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail. (Exception from HRESULT: 0x800736B1)"
ErrorCode=-2147010895
InnerException:

morgan
NaturalPoint Employee
NaturalPoint Employee
Posts: 200
Joined: Tue Jun 24, 2008 2:01 pm
Location: Corvallis, OR, USA
Contact:

Re: Unable to load NatNet.ML (side by side configuration)

Post by morgan » Thu Apr 15, 2010 3:28 pm

It looks like an SxS issue with the vc runtime dependency.

Can you verify you have the 4053 rev of the VC runtime on your fresh Vista 32 install:

C:\WINDOWS\WinSxS\x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.4053_x-ww_e6967989

Post Reply