Quaternion problem with VRPN and virtools

NatNet, VRPN, TrackD, and Plugins
Post Reply
Posts: 1
Joined: Wed Sep 14, 2011 4:15 am

Quaternion problem with VRPN and virtools

Post by janierik » Wed Sep 14, 2011 11:55 pm


When trying to receive the position and quaternion information using VRPN and the building blocks Virtools provides, I run into the following problem. The position data is transferred ok, but the quaternion not. When testing with a separate program the data from the VRPN looks ok, but is not ok in Virtools. When trying to use the quaternion, either only 0's or 1 or -1 are given or some strange out of range information is given. I tried to calibrate it in different ways, but no luck. Do I need to convert or modify the quaternion from VRPN somehow so that Virtools understands the information? Any help is appreciated.

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Quaternion problem with VRPN and virtools

Post by NaturalPoint - Mike » Thu Sep 15, 2011 3:43 pm

Hello -

I would recommend looking at the SampleClient3D application in the NatNet SDK. It contains demo code for quaternion use.

Post Reply