5.2 doesn't load at start up

Post Reply
Razor18
Posts: 15
Joined: Sat Sep 20, 2008 1:02 pm

5.2 doesn't load at start up

Post by Razor18 » Sun Jan 13, 2013 12:29 pm

Hi,

I have no issue with my TIR5, except not loading with Windows despite "Run at System Startup" box being checked. Running "msconfig" to check automatic startup programs, proper box in naturalpoint's row also checked, so I really dunno...

Any advice?

Thanx

jolsonsalem
Posts: 323
Joined: Thu Oct 11, 2012 9:18 am

Re: 5.2 doesn't load at start up

Post by jolsonsalem » Tue Jan 15, 2013 10:00 am

You may want to check in the system tray with all the icons down by the clock. By default Windows will hide a lot of the icons so you may have to click the up arrow and check to see if you have TrackIR icon in there.

Tappi
Posts: 4
Joined: Wed Jan 23, 2013 12:06 pm

Re: 5.2 doesn't load at start up

Post by Tappi » Wed Jan 23, 2013 12:13 pm

Hi,

had the exact same issue with a fresh install of Win 8. Autostart entry is there, nothing loads at startup.

I deactivated the Autostart in the Track IR software and created a task in the task scheduler with "high privileges".

Guess windows blocked the autostart because the executable requires admin rights.

jolsonsalem
Posts: 323
Joined: Thu Oct 11, 2012 9:18 am

Re: 5.2 doesn't load at start up

Post by jolsonsalem » Wed Jan 23, 2013 12:32 pm

Some configurations and permissions settings can cause the newer versions of TrackIR to not run at startup because of UAC. And you've already described the work around :)

Razor18
Posts: 15
Joined: Sat Sep 20, 2008 1:02 pm

Re: 5.2 doesn't load at start up

Post by Razor18 » Wed Jan 23, 2013 2:41 pm

I already set the software for "Running as system administrator". Isn't it enough?

Tappi
Posts: 4
Joined: Wed Jan 23, 2013 12:06 pm

Re: 5.2 doesn't load at start up

Post by Tappi » Wed Jan 23, 2013 3:08 pm

@Razor18: Even if you do this Windows will prompt you with a UAC window and ask for permission which it does not do with autostart applications.

Here is an extensive How-to for the Windows task scheduler:
http://www.techrepublic.com/blog/window ... eduler/616
Edit: The description is for Vista but works the same in all newer versions.

@Jeff: In my case the configuration is MS Windows 8 defaults. Which means UAC, WIn Defender etc. enabled. Isn't it supposed to work in this stock configuration!?

jolsonsalem
Posts: 323
Joined: Thu Oct 11, 2012 9:18 am

Re: 5.2 doesn't load at start up

Post by jolsonsalem » Wed Jan 23, 2013 3:31 pm

When we went to version 5.2 we had to use some elevated privileges that UAC will still ask for confirmation even if you are using an administrator account or have the Run as Administrator option set. The only workarounds we have at this time is either launch it manually, use task scheduler, or disable UAC.

Manual launch is my personal preference with task scheduler coming in second. Disabling UAC has security draw backs and I don't recommend disabling it.

M@rCZyn
Posts: 1
Joined: Thu Oct 01, 2015 2:23 am

Re: 5.2 doesn't load at start up

Post by M@rCZyn » Thu Oct 01, 2015 2:25 am

Hi,

I disabled UAC completely and my TrackIR 5.2 still does not start automatically after restart on Windows 10.

regards
M@rCZyn

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: 5.2 doesn't load at start up

Post by MikeWitham » Fri Oct 02, 2015 9:48 am

M@rCZyn,

We're looking into a solution for this, but the task scheduler solution is the best one we have right now.

Regards,
Mike Witham
TrackIR Product Manager

Post Reply