TrackIR 5.2.2 Final released

StabbedBadger
Posts: 1
Joined: Wed Aug 07, 2013 3:07 am

Re: TrackIR 5.2.2 Final released

Post by StabbedBadger » Wed Aug 07, 2013 3:15 am

So I just received my TrackIR 5 in the post this morning, pretty excited as my mate's were always raving how good this tech is. Set it all up and downloaded the driver from the website and... ultimately I gave up and came here:

Downloaded all driver setup files applicable for my tech (5.2.2 and 4.2.039) and each one gives a "Error reading setup initialization file" error and closes down.

Here's my spec:

Intel i7 3770K + 64GB RAM + Dual nVidia GTX Ti560 1024MB vRAM (nVidia Surround disabled) + Windows 8 x64

Appreciate any help you're able to give...

Kind regards, Steve

NaturalPoint-Dustin
Posts: 612
Joined: Tue Mar 19, 2013 5:03 pm

Re: TrackIR 5.2.2 Final released

Post by NaturalPoint-Dustin » Wed Aug 07, 2013 4:18 pm

HI there,

Could you please try version 5.1.3 and let me know if you are still having issues.

Best Regards,
Dustin
Technical Support Engineer
OptiTrack | TrackIR | SmartNav

Spoiler
Posts: 1
Joined: Sun Oct 06, 2013 10:39 am

Re: TrackIR 5.2.2 Final released

Post by Spoiler » Sun Oct 06, 2013 11:10 am

10-5-2013
Install Log Entry Begin (Installation):
DirectX version : 09
DirectX version is okay
OS = Win 2K/XP
Component USB from 0 to 1
Component APP from 0 to 1
Component DOCS from 0 to 1
Component MSFS2002 from 0 to 0
Component PROFILES from 0 to 1
Scanning for old INF files - WITHOUT PROMPTING
Clean USB Drivers for 2K/XP : VID_131D&PID_0155
Clean USB Drivers for 2K/XP : VID_131D&PID_0156
Clean USB Drivers for 2K/XP : VID_131D&PID_0157
Clean USB Drivers for 2K/XP : VID_131D&PID_0158
Install USB Drivers for 2K/XP : VID_131D&PID_0155
ReInstallUSBDevices loaded setuphlp.DLL :
Error = 0
Install USB Drivers for WinNTx64 : VID_131D&PID_0155
RegisterDriverINF UpdateDriver4PnP Failed! :
USB\VID_131D&PID_0155 AND G:\Trackir\Drivers\npusbio_x64.inf
Error = 183
SetupCopyOEMInfA Called
Install USB Drivers for 2K/XP : VID_131D&PID_0156
ReInstallUSBDevices loaded setuphlp.DLL :
Error = 0
Install USB Drivers for WinNTx64 : VID_131D&PID_0156
RegisterDriverINF UpdateDriver4PnP Failed! :
USB\VID_131D&PID_0156 AND G:\Trackir\Drivers\npusbio_x64.inf
Error = 183
SetupCopyOEMInfA Called
Install USB Drivers for 2K/XP : VID_131D&PID_0157
ReInstallUSBDevices loaded setuphlp.DLL :
Error = 0
Install USB Drivers for WinNTx64 : VID_131D&PID_0157
RegisterDriverINF UpdateDriver4PnP Failed! :
USB\VID_131D&PID_0157 AND G:\Trackir\Drivers\npusbio_x64.inf
Error = 183
SetupCopyOEMInfA Called
Install USB Drivers for 2K/XP : VID_131D&PID_0158
ReInstallUSBDevices loaded setuphlp.DLL :
Error = 0
Install USB Drivers for WinNTx64 : VID_131D&PID_0158
RegisterDriverINF UpdateDriver4PnP Failed! :
USB\VID_131D&PID_0158 AND G:\Trackir\Drivers\npusbio_x64.inf
Error = 183
SetupCopyOEMInfA Called
Checking for NT OS 32 or 64 bit
Detected NT OS = 64 bit
10-5-2013
Install Log Entry Begin (Mode = REMOVEALL ) :
OS = Win 2K/XP
Component USB from 1 to 0
Component APP from 1 to 0
Component DOCS from 1 to 0
Component MSFS2002 from 0 to 0
Component PROFILES from 1 to 0
De-Install USB Drivers for 2K/XP : VID_131D&PID_0155
De-Install USB Drivers for 2K/XP : VID_131D&PID_0156
De-Install USB Drivers for 2K/XP : VID_131D&PID_0157
De-Install USB Drivers for 2K/XP : VID_131D&PID_0158

Padautz
Posts: 1
Joined: Wed Aug 20, 2014 3:01 pm

Re: TrackIR 5.2.2 Final released

Post by Padautz » Wed Aug 20, 2014 3:11 pm

I noticed that newly created profiles are not properly saved if you put a colon ":" in the name.
For example I created a profile named "X3: Albion Prelude".
In the profiles folder there was only a file created with name "X3". (And btw, also in the parent folder, which is probably not intended as well...)

I am completely new to TrackIR and version "5.2.2 Final" is the first I used.
Therefore I do not know if this behavior is new or an "old hat" for you.

Maybe such names should be rejected by the software or problematic characters removed before creating the file name.

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TrackIR 5.2.2 Final released

Post by MikeWitham » Fri Aug 22, 2014 9:06 am

Padautz,

Thanks for the heads up. I'll have to look into that.
Mike Witham
TrackIR Product Manager

SwiftyOne
Posts: 3
Joined: Sun Apr 08, 2012 7:41 am

Re: TrackIR 5.2.2 Final released

Post by SwiftyOne » Sun Dec 21, 2014 12:43 pm

Hello :D

I'm finding just recently that, I've been having crashing with the software v5.2.200(Build 14548) When I say crashing, I cannot tell if it's software or hardware(Camera) related?

I have completely uninstalled the software (using Revo Uninstaller Pro) and reinstalled the software but this, has made no difference at all ...The problem is as follows:
While using TrackIR, I would get a camera freeze (this freeze would happen in all my driving games, and is not related to any one game)and I need to exit the game, where I can see the software had crashed..But instead it's not a software crash, you can still operate the software, and change things, it's just the display screen that's frozen, rather like, when you first start up TrackIR and there's no TrackClip or TrackClipPro, so that the display screen will not be moving, my crashes have been like that, I have it working fine, just before starting a game. I use the TrackClip fitted to a baseball cap, I don't own a TrackClip Pro.
When I have these freezes, I have to then close TrackIR, but the camera's LED's stay lit, (checked with Task Manager that the software has shut down, and it has!) when I startup the software again, all the camera's LED's then go out.. So that I have to shut down, and restart the TrackIR software again (twice) when that's done, it's back to normal again, until the same crash happens some hours later Is there a way of testing the camera to see a fault?

Thanks for any help

Swifty

MikeWitham
NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TrackIR 5.2.2 Final released

Post by MikeWitham » Mon Dec 22, 2014 1:59 pm

Swifty,

This is an interesting problem. Would you mind making a ticket for me at help.naturalpoint.com? I'd like to get to the bottom of this issue and try a few solutions before we post our findings on the forums.

Regards,
Mike Witham
TrackIR Product Manager

SwiftyOne
Posts: 3
Joined: Sun Apr 08, 2012 7:41 am

Re: TrackIR 5.2.2 Final released

Post by SwiftyOne » Mon Dec 22, 2014 3:13 pm

Yes, not a problem :)
Sorry I did not need that information.....Opened a ticket as requested ....Thank you :)

Post Reply