Page 1 of 1

TrackIR and Prepar3D not recognizing [RESOLVED]

Posted: Fri Feb 23, 2018 5:30 pm
by javih6947
Hello

I purchased a brand new pc (parts to build it really) to specifications of Lockheed Martin's Prepar3D simulation software (professional License if that matters). I built my pc, got my updates installed, and then went to download the final peice which was P3D.

Then after installing, updating and actually running Track IR it seemed to have registered without ANY issue. It tracks perfectly, looks great, no problem....until i launch P3D... then I just CANNOT get P3D to recognize the software.

I've tried installing Simmconnect file to P3D main folder. uninstalled it, repaired it. I launch Track IR in the background when P3D is running (as i was informed to do) and still nothing.

Not sure if there's some sort of key binding i'm just missing entirely inside P3D, or if maybe missing a file altogether.....

Eithehr way, any help with this would be AMAZING!

Thank you,
Desperate Simviator

Re: TrackIR and Prepar3D not recognizing [RESOLVED]

Posted: Mon Mar 26, 2018 3:47 pm
by Chris.Johnson
Hello javih6947,

Is the tracking working properly in the TrackIR software? TrackIR should be working properly there in order for it to connect to Prepare3D.

If TrackIR is working fine on the TrackIR software and it only fails to connect to P3D, you can try resetting the SimConnect library which is used to communicate with TrackIR server.

Could you check if the files are included in the following installation directory? They are located in these folders:

\Lockheed Martin\Prepar3D v4\redist\Interface\FSX-SP1\retail\lib
\Lockheed Martin\Prepar3D v4\redist\Interface\FSX-SP2-XPACK\retail\lib

If they already exist, try running the included MSI files to reset them. Once you have done that, reboot the computer, and then run TrackIR as administrator, and then run the game with administrator privileges as well.

I hope this helps, please let me know if anything is unclear

Re: TrackIR and Prepar3D not recognizing [RESOLVED]

Posted: Thu Jun 20, 2019 1:45 pm
by pete1959
You need to go into the redist/interface directory. On the SP1 and SP2 files you need to actually click on each of them the first time and you will get a dialog box asking you to "accept the terms" to use the software. After that it works properly.

Re: TrackIR and Prepar3D not recognizing [RESOLVED]

Posted: Sun Jun 30, 2019 7:02 pm
by Stratt01
Both myself and a colleague have tried this fix and we still can't get TRI to connect to P3Dv5

Re: TrackIR and Prepar3D not recognizing [RESOLVED]

Posted: Mon Jul 01, 2019 2:28 pm
by Chris.Johnson
Hello Stratt01,

Thank you for using Track IR and contacting us. Please uninstall items 2-4 below, and follow the rest of the steps. Sometimes the Microsoft Visual C ++ 2013 Redist (x86)m needs to be reset, following the steps below will ensure everything is reset.

1. Unplug the TackIR from your computer.
2. Remove TrackIR from add/remove programs.
3. Remove NaturalPoint Drivers from add/remove programs.
4. Remove Microsoft Visual C ++ 2013 Redist (x86)
5. Delete installer executable from where you saved it.
6. Delete NaturalPoint folder from Program Files x86.
7. Delete NaturalPoint folder from %APPDATA% location. (APPData is a hidden folder)
-C:\Users\[Your.User.Name]\AppData\Roaming\NaturalPoint.
8. Download the latest installer from our website.
-The latest download will also have our latest USB Drivers.
9. Right-click and install as an administrator.
10. Locate the Track IR 5 Icon on your desktop, Right-click and 'Run as Administrator'. (This only needs to be done the first time.)

Re: TrackIR and Prepar3D not recognizing [RESOLVED]

Posted: Sun Jul 07, 2019 1:10 am
by Stratt01
If I go through the reset procedure you recommend, TrackIR connects once. It will not connect again until I go through the reset procedure again... any more suggestions please?