forums.naturalpoint.com

Discussion and Support for the OptiTrack, SmartNav and TrackIR brands by NaturalPoint

Inverted roll after 90°

by TacticalMan » Thu Mar 15, 2018 11:34 am

Camera rolls perfectly when facing forward however when looking to the sides the roll starts to invert itself, this started all of a sudden anybody else got this problem? or know a fix?
TacticalMan
 
Posts: 2
Joined: Thu Mar 15, 2018 11:20 am

by omenaukko » Thu Mar 15, 2018 2:23 pm

I have same problem since the latest windows 8.1 update. :mrgreen:
omenaukko
 
Posts: 1
Joined: Thu Mar 15, 2018 2:19 pm

by Shooternc » Sat Mar 17, 2018 6:03 am

Same problem here. It was working fine last night and I get back on today and it doesn’t work anymore. Completely out of the blue.
Shooternc
 
Posts: 1
Joined: Sat Mar 17, 2018 5:59 am

by Remontti » Mon Mar 19, 2018 2:03 am

Same here. I'm using Trackir5 and TrackclipPro. Same results with Trueview on and off.
Remontti
 
Posts: 2
Joined: Mon Mar 19, 2018 1:24 am

by TacticalMan » Thu Mar 22, 2018 9:07 am

Do he people with the problem also have the developer mode on windows?
TacticalMan
 
Posts: 2
Joined: Thu Mar 15, 2018 11:20 am

by joe.lee » Thu Mar 22, 2018 1:12 pm

Hello everyone,

Did this start happening more after the windows update? The problem discussed in this thread sounds like a gimbal lock problem that happens when the head orientation reaches ~90 degrees. At this orientation, one of the rotation axes may get lost due to gimbal lock and the head roll may start contributing to pitch instead. However, this behavior existed before so I am not sure what could have changed it. If this is causing a problem, I would suggest dampening down the roll tracking under the advance tracking settings.

Regards
Joseph Lee
NaturalPoint | Customer Support Engineer
joe.lee
 
Posts: 26
Joined: Thu Nov 12, 2015 10:57 am

by pth1701 » Fri Mar 23, 2018 9:36 pm

Getting the exact, same thing.

After I turn my head past the 90 degree mark, the roll axis inverts.

This is a brand new issue, only noticed it today. It's worked perfectly for 2 years.

No matter what settings I change, nothing restores how it used to function only days ago!
pth1701
 
Posts: 1
Joined: Fri Mar 23, 2018 9:32 pm

by joe.lee » Mon Mar 26, 2018 1:42 pm

We are still not sure what could have changed it, we are having no luck with reproducing the issue, or the change in behavior, reported in this thread. Could someone revert back to an older version of windows update and confirm that this changed? I would suggest disabling or dampening down the roll rotation in the tracking. It should improve the gimbal lock issue.
Joseph Lee
NaturalPoint | Customer Support Engineer
joe.lee
 
Posts: 26
Joined: Thu Nov 12, 2015 10:57 am

by Remontti » Thu Mar 29, 2018 3:11 am

I tried the older versions available in the download section - no help.

I get this issue in IL-2 Battle of Stalingrad and in TrackIR software. The issue was discussed at IL-2 forum and it was said that it was not an issue in other simulators (DCS, Rise of Flight etc.). Most likely the problem is linked to the recent patch of IL-2. They also said that in TrackIR software (the 3d head) has always behaved like this although it worked correct in simulators.

For now I just disabled the roll axis.
Remontti
 
Posts: 2
Joined: Mon Mar 19, 2018 1:24 am


Return to TrackIR 5

cron