Defective TrackIR5?

Post Reply
Posts: 2
Joined: Mon Jan 13, 2020 6:08 pm

Defective TrackIR5?

Post by mbulsk » Mon Jan 13, 2020 6:22 pm

After years of wanting to, last week I finally made the decision to purchase the TrackIR5 and TrackClipPro.

It arrived this evening, and I was thrilled to be able to get it working! Installation went very smoothly and I followed all included instructions for setting it up. Initially I used just the TrackClip and it worked fine with IL-2 BoS.

After flying around for a bit, I went to setup the TCP and plug the USB for the TrackIR camera into the TCP's female USB power supply. All of a sudden, I no longer had any LEDs lit on the camera (the TCP LEDs were still lit). The TrackIR software no longer detected any device.

I've tried uninstalling/reinstalling the software and drivers, restarting my machine, trying multiple USB ports, but nothing seems to work. It seems as though my computer doesn't even recognize that the camera is plugged in anymore (no NaturalPoint devices or any 'unknown' devices show up in Device Manager).

I would be extremely grateful if someone could point me in the right direction for further troubleshooting; or, if it sounds like it's kaput already, kindly let me know the best way to proceed.

Please feel free to ask for any other relevant information I may have missed. Any help would be very appreciated!

NaturalPoint Employee
NaturalPoint Employee
Posts: 139
Joined: Tue Aug 15, 2017 1:56 pm

Re: Defective TrackIR5?

Post by Chris.Johnson » Tue Jan 21, 2020 3:42 pm


Have you tried keeping the two USB plugs separate in different USB ports? Also, make sure you are plugged directly into the computer, or if you are using a USB Hub, it has to be a powered one.
All the Best,
Chris Johnson
Customer Support Engineer

Post Reply