Error with my TrackIR 5

Post Reply
dgagnon99
Posts: 3
Joined: Tue Oct 27, 2009 2:20 pm

Error with my TrackIR 5

Post by dgagnon99 » Tue Oct 27, 2009 2:30 pm

Hello all,

I just started having a strange problem with my TrackIR. When I started it yesterday, I saw no light from my device and the software reported as no device connected. In my device manager, I have an unknown device. I have unplugged and replugged the TrackIR with no change.

I then decided to remove the software, but this is where I am getting stuck. Every time I attempt to remove the software, it goes on a spin for a while and then come up with the following error msg:

"Error extracting support files: Server execution failed"

I have rebooted my system on a few occasions and still get the same message.

Is there a way to manually remove the software and drivers so I can re-attempt to install my TrackIR?

Thanks for any advice.

My System specs:

Win 7 Pro (64)
12Gb Ram
1 TB HD SATA
8800 GTS x 2
ASUS Rampage II Extreme
Sound Blaster X-Fi MB

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: Error with my TrackIR 5

Post by VincentG » Wed Oct 28, 2009 2:24 pm

You can delete the TrackIR folder, under Program files (x86), then delete the following key, within the registry.

TrackIR 5 (Windows 7)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Microsoft\Windows\CurrentVersion\Uninstall\{F3CA05B7-B4C0-4C9B-AAA6-16B868B35DF2}

dgagnon99
Posts: 3
Joined: Tue Oct 27, 2009 2:20 pm

Re: Error with my TrackIR 5

Post by dgagnon99 » Wed Oct 28, 2009 3:34 pm

Hi Vincent,

I have attempted your solution (including rebooting my system and reducing all running services and applications). Unfortunatly, It did not work and I am still getting the same error msg. I look into my Event log and took a screen capture of the error msg that seems to be associated with my problem. I am unsure of how to send it to you through the forum.

The error is Event 10010: Distributed COM and the actual error msg is:

"The server {22D84EC7-E201-4432-B3ED-A9DCA3604594} did not register with DCOM within the required timeout."

I understand that this is the key for the Installshield engine. I have installed other softwares recently and did not perceived any problem with Installshield. I can certainly use some hints on this one.

RAFGunner
Posts: 9
Joined: Thu Oct 29, 2009 9:48 am
Location: UK (Swindon) US (VA) Spain (Alicante)

Re: Error with my TrackIR 5

Post by RAFGunner » Thu Oct 29, 2009 10:50 am

You could try running ccleaner and see if that clears up the registry glitch.


Sidenote: I though DCOM was part of the networking side of Windows?

dgagnon99
Posts: 3
Joined: Tue Oct 27, 2009 2:20 pm

Re: Error with my TrackIR 5

Post by dgagnon99 » Thu Oct 29, 2009 3:21 pm

It's alive...

Gunner, thanks for the tip but that was not what did the trick.
I had to update the iKernel.exe file (c:\program files(x86)\common files\Installshield\engine\6\Intel 32)in order for it to work. The page where I found the update is located at:

http://consumerdocs.installshield.com/s ... &sliceId=1

Now, back to the fun.

Thanks to all for your advice and suggestion.

RAFGunner
Posts: 9
Joined: Thu Oct 29, 2009 9:48 am
Location: UK (Swindon) US (VA) Spain (Alicante)

Re: Error with my TrackIR 5

Post by RAFGunner » Fri Dec 04, 2009 10:11 am

Good to hear. Have fun!!!

Post Reply