Extreme Visual Noise in TrackIR 5

lambda09a
Posts: 4
Joined: Tue Dec 07, 2010 8:21 pm
Location: New Zealand

Extreme Visual Noise in TrackIR 5

Post by lambda09a » Thu Dec 09, 2010 3:30 am

I purchased a TrackIR 5 and a Track Clip Pro 3 days ago. When I first installed it, and started the "Track IR 5.0 Final B" software, the "3d view" display was jumping all over the place and erratically. I had a look at the camera view, and the screen was full of red horizontal lines. I thought this may have been a light issue, but no matter how I made the room, it still would not work with any usability.
After a while of trying to get it going, I decided to leave it and come back later that day. It worked perfectly without changing anything. This then continued to work for the next day without fault, until...
I tried to use it this afternoon when I got home from work, and it was back to it's erratic self. Camera view was full of "noise" and it seemed as if it was reflecting from everything in the room. I even changed the "light filter threshold" to the max setting. Doing this did improve the camera view, but there was still alot of random moving red and sometimes green dots. There is now was it was usable at all. After shutting down my computer, and unplugging and plugging back in the trackir and trackclip pro, still no improvement. I decided to uninstall the software and reinstall.

WOW, it was fixed. Camera showed only 3 smallish green dots tracking my track clip pro, and no noise. I then decided to import my profiles that I had setup for FSX so I shutdown trackIR 5.0b Final and copied the profiles folder back over. Restarted the trackir software and it was back to it's erratic self....AGAIN.

Since then I have un-installed and reinstalled the software and it will not work correctly again. I even tried the previous version of the software, 4.1037.Final.B

Extremely frustrated and thinking this thing is faulty, I decided to turn to the forums.

My specs are:
Windows 7 64bit Home Premium
AMD Phenom X4 9950 BE
5GB DDR 2 800mhz RAM


Please if anyone can tell me if this is unusual or have any suggestions please reply.

Karl

Seth Steiling
Posts: 1366
Joined: Fri Jun 27, 2008 11:29 am
Location: Corvallis, Oregon

Re: Extreme Visual Noise in TrackIR 5

Post by Seth Steiling » Thu Dec 09, 2010 10:42 am

Hi Karl,

That does indeed sound like the device's imager has failed. This isn't common, but it does happen on rare occasions. Can you provide a screen shot of the Camera View so we can confirm the behavior before moving forward with a product replacement?
Marketing Manager
TrackIR | OptiTrack

Lokki
Posts: 4
Joined: Thu Dec 09, 2010 12:45 pm

Re: Extreme Visual Noise in TrackIR 5

Post by Lokki » Thu Dec 09, 2010 1:09 pm

I ran to identical problem, but I found out that the problem starts only if I check for game updates in the software. After reinstalling the TrackIR v5 software, the unit worked properly again.

If I uninstalled V5 software after the problem started and switched to V4 software, the problem did not disappear. Deleting the whole Natural Point folder from Program Files before reinstalling did the job.

I also tried to update the games with or without the device detached, and there was no difference.

Raggz
Posts: 10
Joined: Mon Jan 12, 2009 5:19 am

Re: Extreme Visual Noise in TrackIR 5

Post by Raggz » Thu Dec 09, 2010 3:10 pm

I have the exact problem as the first poster and it started today.
I get red noise all over the camera. If i uninstall, reboot and reinstall it's fixed untill i close the TIR software and reopen it.

My TrackIR 5 is just a about a 2-3 weeks old and the second one failing on me though the first one was TIR 4 Pro.

Lokki
Posts: 4
Joined: Thu Dec 09, 2010 12:45 pm

Re: Extreme Visual Noise in TrackIR 5

Post by Lokki » Thu Dec 09, 2010 3:48 pm

Ah, you are correct. I was able to get the problem just by reopening the software and that is basically what the update thing does, because it restarts the software afterwards.

After restarting the computer, everything went back to normal. Reinstalling the software was not needed.

Raggz
Posts: 10
Joined: Mon Jan 12, 2009 5:19 am

Re: Extreme Visual Noise in TrackIR 5

Post by Raggz » Thu Dec 09, 2010 4:18 pm

The thing is i don't wanna reboot every time i want to play. It's weird that it works ok after a reboot. As soon as i close the software and the cam, then restart the sw and cam the problem is back. And the TIR has worked without any problems since i got it a week ago untill today.

I noticed that there are some errors in the install log:

12-9-2010
Install Log Entry Begin (Installation):
Failed! :
USB\VID_131D&PID_0157 AND C:\Program Files (x86)\NaturalPoint\TrackIR5\Drivers\npusbio_x64.inf
Error = 183
SetupCopyOEMInfA Called


Do these errors have any affect?

As you can see the cam is full of noise. Do i send it back for an exchange?
[img:left]http://gethome.no/raggz/tir5.jpg[/img]

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: Extreme Visual Noise in TrackIR 5

Post by VincentG » Thu Dec 09, 2010 5:31 pm

Raggz - I would suggest contacting your place of purchase, for a replacement camera

lambda09a
Posts: 4
Joined: Tue Dec 07, 2010 8:21 pm
Location: New Zealand

Re: Extreme Visual Noise in TrackIR 5

Post by lambda09a » Thu Dec 09, 2010 10:07 pm

Thanks for all your replies. I tried uninstalling and deleting the entire directory before reinstalling, and without updating, but I'm still getting the distortion noise. Check out these photos I've uploaded, note the "light filter threshold"


Image
Image
Image

Note on the last one, the 3 points in the lower right of the display, that's my track clip pro. When it did work, these dots were alot smaller and all green, and there was nothing else but those 3 dots.

Lokki
Posts: 4
Joined: Thu Dec 09, 2010 12:45 pm

Re: Extreme Visual Noise in TrackIR 5

Post by Lokki » Fri Dec 10, 2010 3:54 am

I did have similar errors in my install log. Would you suggest also for me to replace my device, or is this a software problem?

One additional thing I noticed, that when the thing goes haywire, the camera's FOV is a lot more narrower and is offset to the right if observed from user's point of view.

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: Extreme Visual Noise in TrackIR 5

Post by VincentG » Fri Dec 10, 2010 2:20 pm

Please contact your place of purchase

Locked