TrackIR 5 with Software 5.1 No device detected

Bishop
Posts: 5
Joined: Tue Jul 13, 2010 11:34 am

TrackIR 5 with Software 5.1 No device detected

Post by Bishop » Tue Mar 08, 2011 12:29 pm

Hello,

I ran TrackIR 5 with Software 5.0 Final B without Problems for 8 month.
No I�ve installed Software 5.1. At the end of installing Anivirus Avira founds the Trojan TR/Dropper.Gen2 in TIRViews.dll ???

After Starting TrackIR I get the message: No device detected.
I have Win7 64 Bit.
I did an uninstall and installed Version 5.0 again. Same result: No device detected.

The Hardware Manager shows TrackIR 5 with driver version 2.41.00.

I hope you can help.
Bishop

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: TrackIR 5 with Software 5.1 No device detected

Post by NaturalPoint - Mike » Tue Mar 08, 2011 3:05 pm

My recommendation for the installation issue would be to uninstall your current TrackIR software, and delete the following folder:
c:\program files (x86)\naturalpoint\TrackIR

Re-download the installer, and save it to your desktop.
Right click on the installation package, and select run as administrator.
Continue installation as usual.

As for the virus detection, we have checked into this, and we have not been able to reproduce a detection on that file. I would recommend thoroughly scanning your computer to ensure that an infection does not reside elsewhere on it.

dugite57
Posts: 1
Joined: Tue Mar 08, 2011 5:25 pm

Re: TrackIR 5 with Software 5.1 No device detected

Post by dugite57 » Tue Mar 08, 2011 5:28 pm

I got the same message today from Avira - I assume it is a false detection and told Avira to ignor the file.

Bishop
Posts: 5
Joined: Tue Jul 13, 2010 11:34 am

Re: TrackIR 5 with Software 5.1 No device detected

Post by Bishop » Wed Mar 09, 2011 11:31 am

Ok. Deleting the folder before the re-install worked.
Now I have a connect between software and the device.
Thanks.

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: TrackIR 5 with Software 5.1 No device detected

Post by NaturalPoint - Mike » Wed Mar 09, 2011 12:51 pm

Excellent! Glad to hear it.

sperry
Posts: 1
Joined: Tue Oct 05, 2010 6:17 pm

Re: TrackIR 5 with Software 5.1 No device detected

Post by sperry » Wed Mar 09, 2011 6:49 pm

Unfortunately for me, the above process of deleting the installation folder after uninstalling did not allow device detection for me.

I have all the same symptoms and versions of windows and TrackIR drivers as the original post.

The only difference is that my copy of Avira did not detect a virus in the install.

EDIT: By selecting "Update Drivers" in the device manager for the TrackIR device, and pointing to the newly installed c:\Program Files (x86)\NaturalPoint\TrackIR\Drivers folder, my drivers were updated to version 2.50.0.0 dated 11/16/2009 from the older 2.41.0.0 version. My TrackIR immediately began working.

mugwump
Posts: 6
Joined: Sat Mar 12, 2011 2:07 pm

Re: TrackIR 5 with Software 5.1 No device detected

Post by mugwump » Sat Mar 12, 2011 2:10 pm

I am having the same issue. When I updated to 5.1, Windows 7 64-bit no longer recognized my TrackIR5 device. I had been using 5.03 betas with no issues.

I followed the above advice and deleted my old track IR folder, then ran a registry cleaner and reinstalled the newest drivers but the device is not detected.

I reinstalled the beta drivers and Windows can detect the device with them.

I do not use Avira anti-virus.

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: TrackIR 5 with Software 5.1 No device detected

Post by NaturalPoint - Mike » Mon Mar 14, 2011 12:09 pm

When you upgraded to the newest software version, did you remember to run the installer as administrator?

After installing the latest version, did the TrackIR device show up in the device manager?

Do you have UAC enabled? What level is it set to?

mugwump
Posts: 6
Joined: Sat Mar 12, 2011 2:07 pm

Re: TrackIR 5 with Software 5.1 No device detected

Post by mugwump » Tue Mar 15, 2011 8:40 pm

Yes, I ran the installer and administrator.
I have UAC disabled.
I do not know if the device showed up in device manager. I didn't think to check.

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: TrackIR 5 with Software 5.1 No device detected

Post by NaturalPoint - Mike » Wed Mar 16, 2011 2:05 pm

It might be worth it to try to find the TrackIR in your device manager and update the driver software. If you have to manually point windows to the drivers for any reason, they can be found in:

c:\program files (x86)\naturalpoint\trackir5\drivers\

Also, to clarify (because it can be rather confusing), when I said to run the installer as administrator, I meant to right click on it and select "run as administrator". Even if your account is an administrator, this will set different priveleges than if you just double click it.

Post Reply