Baseline 2D not working with every TrackIR 5 Camera

Post Reply
Striezel
Posts: 7
Joined: Fri Jul 16, 2010 8:27 am

Baseline 2D not working with every TrackIR 5 Camera

Post by Striezel » Thu May 12, 2011 4:30 am

Hello!

I know, that the Optitrack Baseline 2D SDK is a retired product, why I don't expect any support, but maybe someone knows a solution for my problem:

I have written a small Application with the latest SDK, which works great with my TrackIR5-Camera (111459). Now, trying the same application with another TrackIR5-Camera (157422) fails. The Camera is not responding, none of the lights lit on startup. Both Cameras work flawless with the TrackIR Software 5.1 though.

Is there any solution to this problem?

beckdo
NaturalPoint Employee
NaturalPoint Employee
Posts: 519
Joined: Tue Jan 02, 2007 2:02 pm

Re: Baseline 2D not working with every TrackIR 5 Camera

Post by beckdo » Thu May 12, 2011 4:47 pm

When developing an application using the latest version of the Camera SDK, it should work properly with all our devices. If that's not the case, we need to take a closer look at why it's not working.

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Baseline 2D not working with every TrackIR 5 Camera

Post by NaturalPoint - Mike » Thu May 12, 2011 4:52 pm

Out of curiosity, is there any particular reason for mentioning the older SDK? If the application was compiled with that SDK, it's drivers, or DLLs, it's entirely possible that the new TrackIR won't work with it, as a change was made requiring new software around for any device with a serial past 155662.

If it was compiled with the latest Camera SDK then there shouldn't be an issue where an older TrackIR worked, but a newer one did not.

Striezel
Posts: 7
Joined: Fri Jul 16, 2010 8:27 am

Re: Baseline 2D not working with every TrackIR 5 Camera

Post by Striezel » Fri May 13, 2011 3:56 am

The Application was written with the Baseline 2D SDK, because it made use of the Vector-Clip.
Since I don't know how many changes would be needed to replace the Baseline 2D SDK with the Camera SDK, I didn't yet consider doing so.

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Baseline 2D not working with every TrackIR 5 Camera

Post by NaturalPoint - Mike » Fri May 13, 2011 4:19 pm

The latest version of the Camera SDK will work with the newer TrackIR 5 devices, as well as the vector clip and TrackClip Pro. SDK versions released previous to december of 2010 will not function with the newer TrackIR 5 cameras, so upgrading would probably be advisable at this point.

Striezel
Posts: 7
Joined: Fri Jul 16, 2010 8:27 am

Re: Baseline 2D not working with every TrackIR 5 Camera

Post by Striezel » Tue Jun 07, 2011 4:33 am

Excuse my late response, but I have one further question:

Are there any other advantages or disadvantages of the newer product compared to the older one in any way (like: speed, accuracy etc.)?

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Baseline 2D not working with every TrackIR 5 Camera

Post by NaturalPoint - Mike » Tue Jun 07, 2011 10:38 am

The change was due to a manufacturing revision of the TrackIR board, and does not reflect any changes in features or reliability.

Striezel
Posts: 7
Joined: Fri Jul 16, 2010 8:27 am

Re: Baseline 2D not working with every TrackIR 5 Camera

Post by Striezel » Wed Jun 08, 2011 6:51 am

Good to hear that. Thank you for the information.

AlanSL
Posts: 3
Joined: Sat Mar 17, 2012 6:22 am

Re: Baseline 2D not working with every TrackIR 5 Camera

Post by AlanSL » Tue Mar 20, 2012 12:57 am

Is it right, that latest TrackIR5 devices (176837)coudn't be managed via Optitrack Baseline 2D SDK OR this is still possible?

I'm quering because I could not find any comprehensive documentation for CameraSDK while it is available for Optitrack SDK.

Thanks!

NaturalPoint - Mike
Posts: 1896
Joined: Tue Feb 01, 2011 8:41 am
Location: Corvallis, OR

Re: Baseline 2D not working with every TrackIR 5 Camera

Post by NaturalPoint - Mike » Tue Mar 20, 2012 12:26 pm

This is correct. TrackIR 5 units beyond serial 155662 are not compatible with the OptiTrack Baseline 2D SDK.

Post Reply