VS2013 build

Post Reply
Okkin
Posts: 4
Joined: Mon Mar 03, 2014 4:19 am

VS2013 build

Post by Okkin » Wed May 14, 2014 9:32 am

Hi,
I'm working a simulation software. We used previously vs2005 but we now use vs2013. So in order to keep the compatibility with the "Camera SDK" supported hardware I need a vs2013 build of the SDK. Can you provide me one?

Regards,

Nicolas

beckdo
NaturalPoint Employee
NaturalPoint Employee
Posts: 520
Joined: Tue Jan 02, 2007 2:02 pm

Re: VS2013 build

Post by beckdo » Thu May 15, 2014 3:39 pm

We don't currently deliver VS2013 binaries in the Camera SDK. This will likely come in the next few versions. If there is a problem linking against the VS2010 binaries included in the SDK from VS2013, we want to know about it.

Thanks,
Doug

JeDi
Posts: 41
Joined: Thu Mar 10, 2011 3:59 am

Re: VS2013 build

Post by JeDi » Fri Jul 18, 2014 5:01 am

Just as a note: I am using the latest version of the Camera SDK (the 2010 library version) with the Visual Studio 2013 compilers (in combination with Qt 5.3 and Qt Creator). The library links and runs without problems.

Okkin
Posts: 4
Joined: Mon Mar 03, 2014 4:19 am

Re: VS2013 build

Post by Okkin » Wed Jul 23, 2014 7:37 am

Hi,
Until now I could still use vs2005, so I didn't do the test. Now I'm going to have to use vs2013.
I will test the vs2010 lib as JeDI. But according to the msdn informations there is no guarantee on compatibility of vs2010 and vs2013 binaries.

Regards,

Nicolas

Okkin
Posts: 4
Joined: Mon Mar 03, 2014 4:19 am

Re: VS2013 build

Post by Okkin » Mon Aug 04, 2014 8:46 am

Hi,
I have done some test with CameraSDK vs 2010 build and vs2013. I have stack corruption all around every camera SDK object. So the vs 2010 build is not usable with vs2013.
The only option is to create a C wrapper. Right now I don't have time to do this so I will disable the Camera SDK support. I will put it back as soon as a vs2013 build is released.

Regards,
Nicolas

beckdo
NaturalPoint Employee
NaturalPoint Employee
Posts: 520
Joined: Tue Jan 02, 2007 2:02 pm

Re: VS2013 build

Post by beckdo » Wed Aug 06, 2014 2:08 pm

Hey Nicholas,

Are you just getting corruption on object that you are instantiating from your code or other objects?

I'd really like to get more specific details.

We don't currently offer a VS2013 binary, but it'll be coming before too long.

Thx,
Doug

Okkin
Posts: 4
Joined: Mon Mar 03, 2014 4:19 am

Re: VS2013 build

Post by Okkin » Thu Sep 25, 2014 10:11 am

Hi Doug,
Sorry I have missed your reply.
In my memories all objects from the "Camera SDK" lead to a stack corruption.
I can do again some test next week to be more precise. But honestly I doubt a c++ vs 2010 library can be compatible with a vs 2013 software.

Regards,
Nicolas

Post Reply