Maximum of rigidbodies

Post Reply
joe.fz
Posts: 1
Joined: Wed Feb 13, 2019 8:02 pm

Maximum of rigidbodies

Post by joe.fz » Thu Feb 14, 2019 8:52 pm

I was told that Motive 2.1 can support 100+ tracking objects. But when i test about 50 rigidbodies, the data streaming rates fall from 90fps to 50fps or even less. I have tested even i9 cpu, it looks like motive only used one core of cpu to do the caculation.

What can i do now? I didn't use the active marker.

steven.andrews
NaturalPoint Employee
NaturalPoint Employee
Posts: 502
Joined: Mon Jan 19, 2015 11:52 am

Re: Maximum of rigidbodies

Post by steven.andrews » Fri Feb 15, 2019 12:50 pm

Hello joe.fz,

Thanks for reaching out to the community regarding this question. 100+ rigid body tracking is possible with the correct setup.
First, you may want to verify some settings in the rigid body properties and reconstruction settings.

  • "Enhance Performance" should be enabled on every rigid body. This is off by default, but is a setting that is intended for high rigid body counts.
  • "Tracking Algorithm" should be set to Marker Based on every rigid body.
  • Keeping the marker counts low will help with speed, since the passive tracking is less efficient at identifying rigid body patterns with a lot of markers.
  • In the reconstruction settings, set the "Performance/Quality" all the way to Performance.
  • With such high rigid body counts, you will want to make certain Motive is the only application running on the computer

I hope this helps to give you some guidance. If you continue to struggle, please feel free to reach out to us directly and provide a recording (.tak) showing the current results. If you could also provide some additional details regarding your PC specs and the processor model, that would be useful as well.

Best,
Steven
--
Steven Andrews
OptiTrack | Senior Customer Support Engineer
help.naturalpoint.com
support@optitrack.com

Post Reply