Missing sections of data

Post Reply
cmmurphy
Posts: 6
Joined: Thu May 09, 2019 7:45 am

Missing sections of data

Post by cmmurphy » Thu Oct 03, 2019 10:30 am

Hello all,

I'm not sure what is happening, with 2.1.2 we have been getting takes missing huge chunks of data across all markers simultaneously. As if the system shut down for a few frames.
Missing data.PNG
Missing data.PNG (38.5 KiB) Viewed 115 times
Has anyone else been getting this? It seems to happen at random frames and random amounts. Re-calibrating doesn't seem to prevent it from happening.

steven.andrews
NaturalPoint Employee
NaturalPoint Employee
Posts: 528
Joined: Mon Jan 19, 2015 11:52 am

Re: Missing sections of data

Post by steven.andrews » Mon Oct 07, 2019 10:33 am

Hi cmmurphy,

Sometimes a machine may not be able to keep up with the full frame rate of the cameras, and process every single frame. In those cases, you would see the 3D is missing, such as in your graph, while the 2D camera data is continuous. You can check your 2D data to see if the markers are still present during those small gaps you are experiencing. If that is the case, you will just need to reconstruct the data while in Edit mode. As long as the 2D is there, the 3D can be processed again.

Post Process Reconstruction

I hope this helps. If you require any further assistance, feel free to reach out to us directly.

Best,
Steven
--
Steven Andrews
OptiTrack | Senior Customer Support Engineer
help.naturalpoint.com
support@optitrack.com

cmmurphy
Posts: 6
Joined: Thu May 09, 2019 7:45 am

Re: Missing sections of data

Post by cmmurphy » Tue Oct 08, 2019 10:41 am

I conducted a test to see if the 2D data was lost, and it appears that on the scene below it is for a tic. We have a 12 camera system and camera 10 cuts out a few frames before all markers are gone in the scene for a few more frames, then it comes back.

In the top image all markers are gone in the tracking space.
In the next image markers are back but no tracking on cam 10
Third image is the resulting data gap.

Note: Cameras 2,5,8, and 11 are not in a position to see the subject but they are working fine.
Missing data2.PNG
Missing data2.PNG (104.99 KiB) Viewed 30 times
Missing data3.PNG
Missing data3.PNG (85.79 KiB) Viewed 30 times
Missing data3.PNG
Missing data3.PNG (85.79 KiB) Viewed 30 times

Post Reply