Please help Camera/Driver issues????

Post Reply
Worther_1
Posts: 1
Joined: Wed Oct 23, 2019 10:30 am

Please help Camera/Driver issues????

Post by Worther_1 » Wed Oct 23, 2019 10:56 am

Hello All,

Okay, let me try to quickly explain my issue. Win X desktop, have been running Track IR3 (with vector expansion) for years (since 2004 I think). I used it for DCS World everyday. Last week when I opened Track IR5 software (which I've been using since it came out - and its updated to current version) it didn't recognise my camera (no device detected). The camera still makes the windows "bing bong" sound when I plug it in, just not detected by Track IR software.

I have tried the following:
Changed from powered USB (as I've always done) to USB2 and USB3 ports on the PC itself.
Uninstalled, restarted PC, re-installed latest version of software from Natural Point website.
In the Device Manager it shows up as "Unknown Device". Tried to troubleshoot with no luck.

In the end I thought maybe the camera had died from old age, and ordered a brand new setup from R C Simulations (same place I ordered original way back). Camera, track clip and track clip pro.

It came today and I've just re-installed software, rebooted the PC, plugged in camera (as per instructions), and its still the same issue.

I still get the "bing bong" when I plug it in but still getting "No device detected".

Any ideas?
Have I wasted £190?

Any help, advice or assistance will be greatly appreciated.

Regards,

Rich

Jayteeaitch
Posts: 2
Joined: Fri Sep 06, 2019 8:21 am

Re: Please help Camera/Driver issues????

Post by Jayteeaitch » Thu Oct 31, 2019 8:28 pm

Hi Rich

Twice already I have tried to answer your query but somehow it gets lost
Here goes again --- and I hope I am not teaching grandma to suck eggs!!

Although I am new to Track IR -and no expert - 2 questions come to mind

Assuming you are using the pro set and on your earphones - are you sure you have connected
the IR receptor to the special plug with the camera - (or vice versa ?)?
You seem to know that it should be plugged only into a USB on the PC - Mine is on the 3.0

My device manager shows a mini computer picture and the words "Unspecified" and "TrackIr"
i.e. The computer - W10 64bit- recognises the camera

If the light on the left side is not lit - the comp .isn't recognising it

My problem with Track IR that it seems to need manually closing down after every use - and the next time
I use the sim - I have to - close the sim - start TrackIR again - and then the sim again - a real P.I.T.A.!!

Chris.Johnson
NaturalPoint Employee
NaturalPoint Employee
Posts: 118
Joined: Tue Aug 15, 2017 1:56 pm

Re: Please help Camera/Driver issues????

Post by Chris.Johnson » Mon Nov 11, 2019 10:55 am

Hello Rich,

Thank you for reaching out in the forums. The problem here is that the drivers have become corupt, and are not able to properly recognize the device. You will want to delete the NaturalPoint USB Drivers, as well as the Track IR software. Then when you reinstall 'As Administrator' the drivers will reinstall along with the software. You have to uninstall the USB drivers, in order for this to work.
All the Best,
Chris Johnson
Customer Support Engineer
NaturalPoint

Post Reply