compatiblity with P3D V4.2??

Post Reply
MrAflac9916
Posts: 1
Joined: Thu Feb 15, 2018 5:48 am

compatiblity with P3D V4.2??

Post by MrAflac9916 » Thu Feb 15, 2018 5:50 am

hello, when I try to run trackIR with prepar3d 4.2 the game crashes. is this an issue with my computer or has trackIR not been updated to run with it yet?

thanks

Andrew

joe.lee
Posts: 26
Joined: Thu Nov 12, 2015 10:57 am

Re: compatiblity with P3D V4.2??

Post by joe.lee » Thu Mar 22, 2018 2:45 pm

Hello MrAflac9916,

I'm not aware of any breaking changes that were made for v4.2. Prepare3d uses SimConnect library for communicating with TrackIR server. I am suspecting this was somehow not updated properly.

Could you check if this is included in the following installation directory? They are located in these folders:

\Lockheed Martin\Prepar3D v4\redist\Interface\FSX-SP1\retail\lib
\Lockheed Martin\Prepar3D v4\redist\Interface\FSX-SP2-XPACK\retail\lib

If they already exist, try running the included MSI files to reset them. Once you have done that, reboot the computer, and then run TrackIR as administrator, and then run the game with administrator privileges as well. This would reset the libraries and may resolve the problem.

Regards
Joseph Lee
NaturalPoint | Customer Support Engineer

Post Reply